Pre-recorded audio track outputting no sound

I am using Ubuntu 18.04.x with low-latency kernel, Jack and PulseAudio, Ardour 5.12. I routed the output from audio track directly to Jack Source (Pulse Audio), in order recording application Vokoscreen can catch it. But at the end, there no sound in screen recording result.

This is my audio track input capturing the hardware input (this works fine):
See image 1

This the output of audio track, I routed it to jack source (this one does not work, jack source does not receive the audio at all):
See image 2

And I also tried to route the audio track output to master busses (master in) to make sure there is a sound coming from audio track output (but yeah, there isn’t), you can see the right meter is silent there.
See image 3

This is the patchbay of Catia.
See image 4

Images:

And also, when I tried to set master to directly capturing from system in (mic) and routing the output to jack source, it works. So,
System capture (mic) -> ardour ( master ) -> jack source :heavy_check_mark: works
System capture (mic) -> ardour ( audio track -> master ) -> jack source :x: not works

I anyone who has a suggestion about this issue, or maybe had faced this problem too, please tell me.
I am sorry, I am new user, and allowed to upload only one image.
Thanks a lot in advanced.

FYI since you are running Jack, try running jack_lsp -c on the command line and pasting the output here surrounded by CODE blocks. It will give a clearer view of what is patched to where.

Of course I am not sure the ALSA backend wouldn’t work in this situation as well, it doesn’t look like you are routing any additional software into Ardour to require Jack.

1 Like

Of course I didn’t route any additional software (which is Vokoscreen) directly into Ardour, but I set Vokoscreen input to Jack source, and Jack source should listen the Ardour master’s output.

And by the way, my issue was solved, I went to Ardour preferences, went to Signal Flow, and under Monitoring, I changed Record monitoring handled by from audio hardware to ardour. And now everything work as expected. But thanks for replaying me.