Possibly first and last time use of Ardour

Im not one to complain about things. But considering how excited I was to use Ardour for its features as well supporting open source software, It became a huge major let down after using it the first time. I tried it out a bit as the demo but then decided to donate so I could actually register the software. Decided to pull up a mix and get started. I have experience with most other DAWs, and was excited to see all of my favorite features from each in Ardour. I spent several hours on my mix tailoring how I wanted it to be and saved it up once I was finished. I finally decided to pull up the mix and start where I left off, and non of the UA plugins saved even a portion of information. Are you kidding me? I was practically finished with the mix.

I will probably never use the software again now.

If you were excited about open source software, why not submit a bug report about those plugins? Strange though as I am fairly sure we have a variety of folks on Mixbus using UA, though I am seeing more issues on Windows than Mac, which are you on?


It is always lovely to see how DAWs get blamed for issues with plugins. Just lovely.

Also, please note: there is no “registration” for Ardour. It comes without copy protection or licensing schemes. You can choose to pay us if you want to take advantage of the fact that we run build systems to build it for you. Some people prefer to build it themselves. The software remains available without cost to anyone at any time, and can be freely copied without licenses etc.

And, as Seablade noted, you haven’t even indicated which platform you’re on. At least one major platform is not even officially supported at this time.

Maybe he runs demo mode (plug-ins resetting), because if you install demo, then pay you still have a demo version installed.

The demo/free copy from ardour.org hasn’t used plugin settings as the “difference” for several months. We changed it to be silent after 10 minutes (with a reset button).

“Im not one to complain about things.”

Your post suggests otherwise. It doesn’t ask for help, it doesn’t report a problem in a constructive way that could lead to a fix, it just…complains.

“I…decided to donate so I could actually register the software.”

It doesn’t work that way.

“I will probably never use the software again now.”

Ugh. What is the point of the posting this? It sounds like a bitter, uninformative product review written by someone who doesn’t know what they are doing. Do you understand the nature of open-source software? Are you expecting ‘Customer Service’ to reach out and offer their apologies?

If you want to support open-source software, get involved. File a bug report. Get on IRC, talk with others, and get to the bottom of the issue. Then post on the forum what you learned so others can benefit from the knowledge. What you posted here isn’t useful to anybody. It’s just complaining.

I apologize for not being here to reply to comments and posts. First I would like to express that I did post in an upset manner and I also apologize for for doing so. I have used DAWs for over 15 years and I wasn’t prepared to experience such a strong malfunction for one of the most basic functions of the program. I understand that this is open source software and that it is up to the user and the community to support and make the software better. My frustration is my own in that I am very used to commercial DAW systems, which I currently own that allow me to get the work done that I need. No one likes to put all of there artistic effort in to a mix, expecting it to be nearly finished, then come back just to find out that the software didnt save any of your efforts. I have work with deadlines and so I will probably stick to the software that Is tried and trusted. It was not necessary for me to project my anger on the forums, but I also wasn’t sure if a bug report establishing my trust to try again right now.

But on the positive side, I see some amazing potential for this software. It actually seems more complete then most other DAW’s out there and it seems to incorporate all of my favorite things. While adding things that I think are unique. I think it needs a few interface implementations that I expect in a few others, but I could see those coming in future releases of Ardour. I guess really I am excited about the entire project and I am quick to want to jump to the support to open source software. I dont stay particularly attached to any of the main stream DAWs, even though I own licensed serials for the majority of them. Ardour is incredible really.

I dont know what caused the problem with the plugin. I was using iZotope plugins almost exclusively. Im not sure if thats a source of incompatibility. But i havnt been able to put the time in to researching on isolating the problem. When I get some time, I will see what I can figure out and hopefully come back to the forum with something a little more useful and supportive.

I had previously installed the demo version, but I am pretty certain I uninstalled and reinstalled correctly. It’s unfortunate that the incident did occur, but I think I will give it a few more goes and hopefully add some support to the Mac OS.

On a side note, is Ardour a little more Linux friendly of a DAW than on Mac OS?

Oh yes I am running Mac OS Yosemite 10.10.5 . Ill try to isolate the problem a little bit and I will file a bug report if it is replicable.

The interface on all 3 platforms is basically identical. There are no notable differences. The only real change is the choice of primary modifier key (Ctrl on Linux+windows, Command on OS X).

I decided to put some time in to testing out the issue with the plugins today. I have been able to isolate it as an issue with iZotope Ozone 5. It might be other iZotope plugins as well but I havnt tried all the others that I have. I could look in to it further, but I have a feeling it might be across the board with them. I will make several changes to the plugin, save it, exit out, and then return to find things either totally initialized, or just in some totally random setting. However, In my test project I have an Eventide UltraChannel loaded. I messed around with the settings on that plugin, saved, exited, and when I came back everything looked like it had been retained. I will try to report all this in the bug tracker section.

I have a multitrack recording this Saturday I would like to give Ardour another go with. I love how light weight Ardour is, which is one of the main reasons I have appeal for using it. Also it is easy for other people to access if I am giving the multitracks to the client. Im not mixing so it shouldnt have any issues with the plugins. It will probably be between 24-32 channels simultaneous for about an hour of tracking time. Say hard drive capacity and speed are accounted for, does anyone have experience in reference to the stability of Ardour to do this?



Short version is, that should be quite doable. I track 48+ tracks live on a fairly regular basis on Ardour or Mixbus (Which is based on Ardour) myself over Dante with good success. I usually track to a SSD these days and crank up the buffer size on the audio interface as well as the recording buffer size in Ardour.


By the way, don’t just take my word for it, make sure you test THOROUGHLY beforehand obviously. I am a big fan of ALWAYS testing the heck out of something first, and especially if you are using a mechanical drive, if this will be during a live concert make sure you test with similar volume and style of music as mechanical vibrations have been known to cause problems on occasion on a mechanical drive (With really about any software).