port registration error


I just tried to open a session and I got this message:

port registration error
AudioEngine: cannot register port “click/out 1”: a port with the name “click/out 1” already exists: check for duplicated track/bus names
Click the Close button to try again.

Can I do something to recover this session?

hallo scarry,
open the ardour file with an editor (it is called name-of -your-session.ardour and it is in your session folder) and rename everything what say “click/out 1” to sth else, like “xclick/out 1”, “xxclick/out 1” and so on. this should allow you to open your session again. the best, of caurse, is you first make an backup of your session folder.


You probably have a track or bus or send named ‘Click’ which is conflicting with the internal click output in Ardour. As mentioned above manually changing port names is the solution to be able to reopen the session, but definitely make sure you back up your session first.


also, note that current versions of ardour do not allow the creation of tracks or busses with conflicting names. your problem suggests that you may be running an out of date version and should probably upgrade.

this is not right. this bug was resolved a long time ago, but it is present again in the newer ardour2 versions:



What Paul said is correct to a point, 2.x will not let you create tracks and busses with conflicting names, but I don’t believe it checks with the internal ports of Ardour to include Click and Auditioner IIRC.


The session was created with Ardour 2.8.11

OK I rescued my session by renaming everything thats called ‘click’ to ‘xclick’ .

Thanks everyone for the help.

Does this mean the name ‘Click’ is forbidden?

For all intents and purposes yes at this time it is. A Mantis report probably should be filed to change the name of the internal click ports in Ardour as obviously that can be a pretty common name.


Hi, after renaming all instances of ‘click’ to ‘xclick’ I still get a “port registration error” when I try to open two of my sessions where I had recorded a click to a track named “click”. The dialog gives no more info, only “Click the Close button to try again”. Any idea how I could save my sessions?

Moving all regions/tracks/automation to a new project could be a solution if that’s possible, I’m on a deadline that it would be nice to stick to.

Please let me know if there’s any info I could provide to shed some light on the situation.

Yeah…sorry about that folks, I managed to fix the most time critical one with some more editing of the session file. The other faulty session is less complicated so I’m confident I’ll be able to save that one too.

Keep up the great work Paul and all other contributors, looking forward to trying out A3 sometime soon!

Hey sorry for bumping such an old post, but I’m getting a similar error, when I try to open a project that worked yesterday without any trouble.

Port registration error:
AudioEngine: cannot register port “MCWB - Medley 1 (Demo)18_Leo Vocal Main 1/out 1”: No more JACK ports are available. You will need to stop Ardour and restart JACK with ports if you need this many tracks.

Already tried to restart JACK and Ardour with increased port number to max 1024 with QjackCtl, but I’m still getting the same error.


i am not 100% sure but i think that if you are using jack2 the max. port count is hardcoded at compile time or such…

which version of jack are you using?



jackd2 1.9.8~dfsg.4+20120529git007cdc37-2ubuntu1

…well now it seems to work …just restarted ubuntu 12.10 (64bit) with the interface pluged in (Focusrite Scarlett 2i2)… so it seems that it works sometimes and sometimes not - hope i can figure out whats exactly the problem oO

It is possible you were running into an issue of ports not being torn down correctly, would require much more debugging to find out for certain however.