pluguins help compiling the calf from synaptic

help compiling or doing calf repository plugins from synaptic, because in the form on the web explaining to do in calf termanial all pluguins not work, at least to me please help me, I have several days and have not have nothing.


I don’t use Ubuntu or PPA’s myself but I think these are the commands you will need to use:

sudo add-apt-repository ppa:kxstudio-team/ppa
sudo add-apt-repository ppa:kxstudio-team/plugins

This will get you the main KXStudio PPA plus the Plugins PPA, please note there are more KXStudio PPA’s but this should get you started.

If you want to make music with Ubuntu perhaps you should look at Dream Studio or KX Studio where all of this stuff is set up for you already.

Hi Gmaq,
Could you give me the full command is that I try and not working.
did so, ~ KXStudio-team / calf-plugins / ppa

does not work.

Hi sandydlr25,

If you want the latest Calf plugins and are using Ubuntu you will need to add some optional software repositories (now called PPA’s) to your existing Ubuntu 12.10 install. The ‘KXStudio’ PPA will have what you are looking for and MUCH more…

See here:

Hopefully Google translate can help you understand how to add the new PPA to your system.

Hello, Donf, I was reviewing my problem is the calf version of plugins that I installed is 0.18.63, not the latest, I hope you now understand and can help me to update the installed package to the latest version.

I’m trying to make sense of what you wrote. :slight_smile:

I think you wrote that you did “apt-get install-plugins pantorrilla” (which is a very literal translation into Spanish of “apt-get install calf-plugins”), and you got a response saying “Invalid operation” or something like that.

You must enter the command EXACTLY like this, without translating it:

sudo apt-get install calf-plugins

Building from source code is much more complicated. If that is your only way forward, you may need to find someone to help you who knows Linux, English and Spanish.


apt-get install-plugins pantorrilla, so as not working, tells me that the order is invalid, when I tell you that I downloaded from the official website is (, as explained here http://calf / download.html, nothing does not work, the only way that worked was downloading the installation package calf as archive and installing it with the Ubuntu installation manager and the missing plugins package that has calf . I hope you understand.

Hello donf, the Linux version I use is Ubuntu 12.10, I downloaded the calf plugins from the official website and install the folder from the terminal, but when continuing to do the repositories will not let me, tells me that the directory used fatal not found, then I leave the terminal and entered ardor and me missing plugins, which are coincidentally my interest, I do not know if you understand, but explain more or less everything that goes on and done.
I hope you can help with this.

It is not completely clear what you mean by “official website”. Ubuntu’s web site? Sourceforge? Something else?

Also, “install the folder from the terminal” is not completely clear to me. What command, exactly, did you enter in the terminal window?

(I recognize that we have a language barrier, and I’m trying to be certain that I understand you, and to avoid making assumptions about what you mean.)

Did you try

apt-get install calf-plugins

as recommended on

If you have not yet tried this, please do. It might work for you.


hope for your help in this post, please.

I’d like to help, but I’m not sure where to begin. Can you explain (1) what you have done so far, (2) what results you expected, and (3) what actually happened?

What Linux distribution are you using, and what version?