Plugins not picking up + Piano roll problems

I don’t know if this is allowed, but i have two, vaguely related problems that i would like to deal with and i am just going to post them in this one post so I’m not cluttering up the forums.

First problem: Whenever i try adding a new plugin i will go through all the motions of putting it in a designated spot that i have specified in the plug in directory, scanning for the plugin and all that fun stuff. But they are almost never picked up by the program with the exception of “Dragonfly reverb”. I have sort of been putting this off for a while, but i would really like to start adding some virtual instruments. I am having this problem both on Windows and on linux.

Second problem: In most programs with piano roll when you place down and move a note the program will play it back to you so you can easily get things done. I cannot seem to get ardour to do this. I’ve tried just using the piano on the left of the screen to figure out where i want to put a note and THEN putting it down, but its painfully inefficient. I do know you can do this in ardour because i’ve seen people doing this in videos, specificity alot of Unfa stuff. What can i do to turn this feature on?

re (2): Preferences > MIDI > Audition > Sound MIDI notes as they are selected in the editor

As for the plugin issue: What plugin standard? VST? LV2? Any specific plugins?

1 Like

Thank you, that worked perfect for the midi! Shouldn’t something like that be turned on by default?

Anyways, its all plugins it seems. Vsts on windows and whatnot. The only plugin it will recognize from my personal list is Dragonfly reverb.

https://manual.ardour.org/appendix/files-and-directories/ explains where the plugins should be installed for Ardour to be able to see them.

You probably have to go to Edit/Preferences , Plugins/VST and enable the scan if you want new VST-plugins to show up; at least if you’re using Linux.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.