Plugin wont scan

Hello everyone

I have just installed Manjaro Qonos 21.2.1 . All looking pretty good so far however I have a favorite plugin the Harrison 32C Channel. This is installing from the terminal no problem however Ardour reports when it scans it :

[ERROR]: Could not load VST2 plugin ‘/usr/lib/vst/32C-Channel.so’: libcurl-gnutls.so.4: cannot open shared object file: No such file or directory
[WARNING]: Cannot open VST2 module ‘/usr/lib/vst/32C-Channel.so’

This installs on a separate machine running ubuntu 20.04 LTS no problem

Is this an issue with Manjaro ? or the plugin or Ardour ?

Any response most welcome , thanks in advance : )

Alastair

From the Manjaro forum , this fixed it :
pamac install libcurl-gnutls

sudo pacman -Ss libcurl-gnutils*

To see if the package is available

sudo pacman -Syu libcurl-gnutils*

To install it.

I use Fedora so there may be mistakes here…

TY datho for your help :slight_smile:

This is a long standing issue about some of Harrison’s plugins, see e.g. this thread in Mixbus Forum.
Depending on your distro there might or might not exist a package libcurl-gnutls, here in openSUSE it doesn’t - after talking to Ben Loftis in IRC, I created a symlink /usr/lib64/libcurl-gnutls.so.4 → libcurl.so.4 and that fixed it.
Hope that helps!

EDIT: Oh I’m late, I see that while I wrote this you got it sorted by help of others :slight_smile:

Thanks for your kind assistance :smiley: sorted now .