Please help me recover this session (std::bad_alloc)

Ahoy!
I actually had some time to make some music this morning. things were humming along nicely until I tried to figure out why my summary was showing hours and hours when my song is just 3 minutes. So I wanted to see if there was a random region out there so I dragged the view all the way to the right then kept dragging even further just because I was curious what would happen. Well then ardour crashed and now I can’t load that session (other sessions load fine).

When I run ardour in the terminal and load the session this is what I get in the output:

Ardour5.12.0 (built using 5.12 and GCC version 5.2.1 20150903)
ardour: [INFO]: Your system is configured to limit Ardour to only 4096 open files
ardour: [INFO]: Loading system configuration file /opt/ardour/etc/system_config
ardour: [INFO]: Loading user configuration file /home/spencer/.config/ardour5/config
ardour: [INFO]: CPU vendor: GenuineIntel
ardour: [INFO]: AVX-capable processor
ardour: [INFO]: CPU brand: Intel® Core™ i7-4765T CPU @ 2.00GHz
ardour: [INFO]: Using SSE optimized routines
Cannot xinstall SIGPIPE error handler
ardour: [INFO]: Loading default ui configuration file /opt/ardour/etc/default_ui_config
ardour: [INFO]: Loading user ui configuration file /home/spencer/.config/ardour5/ui_config
Color shuttle bg not found
ardour: [INFO]: Loading color file /opt/ardour/share/themes/dark-ardour.colors
ardour: [INFO]: Loading ui configuration file /opt/ardour/etc/clearlooks.rc
ardour: [INFO]: Loading ui configuration file /opt/ardour/etc/clearlooks.rc
Found nothing along /home/spencer/.config/ardour5/templates:/opt/ardour/share/templates
run dialog
convolution: samplerate mismatch preset:48000 host:44100
convolution: samplerate mismatch preset:48000 host:44100
convolution: samplerate mismatch preset:48000 host:44100
convolution: samplerate mismatch preset:48000 host:44100
convolution: samplerate mismatch preset:48000 host:44100
convolution: samplerate mismatch preset:48000 host:44100
convolution: samplerate mismatch preset:48000 host:44100
convolution: samplerate mismatch preset:48000 host:44100
convolution: samplerate mismatch preset:48000 host:44100
convolution: samplerate mismatch preset:48000 host:44100
convolution: samplerate mismatch preset:48000 host:44100
convolution: samplerate mismatch preset:48000 host:44100
Scanning folders for bundled LV2s: /opt/ardour/lib/LV2
Set cursor set to default
terminate called after throwing an instance of ‘std::bad_alloc’
what(): std::bad_alloc
watched PID no longer exists - releasing device.
Aborted

The session is pasted here: https://pastebin.com/ja8t2CV2

I imagine I just need to figure out how to set the current view to something sensible but I can’t find the XML tag on my own to do so. If some GDB debugging is necessary let me know, I’ll do that. This is on Debian with KXstudio build of ardour if it makes any difference

Please join us on IRC.

Maybe delete the instant.xml file in the session’s folder. The editor’s zoom level is saved there.

We’ve seen cases that allowed to zoom out to show session-duration beyond our sun’s lifetime :slight_smile: …and then on next session load Ardour’s GUI runs out of memory computing music-time bar beat location positions for the ruler.

PS. Make a backup and/or pastebin instant.xml

I will try that. Thanks! I’ll join you on IRC if that doesn’t work.

Changing the left-frame value in the Editor tag a few orders of magnitude did the trick! Thanks so much!