Playing very short ranges within regions

Hi. I want to play very short ranges.

Today, specifically, I want to show students how reducing a range progressively changes a sound from a piano note attach to a click. I select a portion of sound with the range tools: listen, shorten, listen… etc.

But Ardour doesn’t seem to want to play less than about 0.2" of sound. Even when I select less than that, it plays (what sounds like) 0.2" of the underlying region. It seems to be playing sound AFTER the selection, so if I choose a tiny region before an attack, I hear the attack as well.

If I actually make regions and put them in space on a track, then yes, it plays just what’s there down to a single sample, but I want to hear what I have selected before cutting/copying.
Is there a setting I’m missing somewhere to fix this?

Conversely I might select a tiny region, listen, think it’s ok, bounce or save as a region, only to find that it’s shorter than what I thought I had selected.

You have to disable region-fades, and de-click

Menu > Session > Properties > Fade

By default ardour does short fades to prevent loud transients on region borders and when starting to roll.

Thanks for the swift response! However, this doesn’t fix it for me.

I just unchecked all of the boxes in Session Properties > Fades

I then went back and selected a region 0.50" before (i.e. leading up to) the high piano attack. I still hear the attack when I audition the range even though the waveform is outside the selection.
If I copy the range into a new track to listen, it definitely has no attack (it was pretty obvious from the waveform anyway)

Pulling back the end of the selection from the attack I need to leave 0.02" space before I don’t hear the attack. Is this a bug?
(Ardour 6.3 Mac OS X 10.15.6)

update… this seems to be directly related to buffer size.
In Audio/MIDI setup, the bigger the buffer the more Ardour plays beyond the selection. Actually switching declick and fades back on (In Session Properties) doesn’t seem to make any noticeable difference to the length of what is played beyond the selection, but of course does soften the click.

I have just tested this. Playback starts at precisely the playhead position.
http://robin.linuxaudio.org/tmp/roll-start-test.ardour-session-archive

If it was early, the square wave on track 2 would be seen in the scope, if it was late the spike on track 1 would not trigger the scope:

The session: http://robin.linuxaudio.org/tmp/roll-start-test.ardour-session-archive
(uses https://x42-plugins.com/x42/x42-scope)

Now there may well be something different on your session. Would you mind filing a bug report and attach the session, or provide a recipe how to reproduce the issue?

Done. 0008430
thanks

A