Playhead reposition noise on input channel


(Martin Bruset Solberg) #1

Hi

I’m running Ardour 5.12 on Fedora 29 x86_64, and I’m experiencing the following issue:

I have an audio track with input coming from my USB audio interface (Native Instruments Audio Kontrol 1). Whenever the playhead is repositioned, from manually moving it, looping or auto returning, there is distortion on the incoming audio, audible as a click/glitch noise. There is no noise when moving the playhead when the incoming signal is silent. The noise is visible when putting a spectrum analyzer on the track.

What can be the cause of this? Is it Jack configuration? The current setup is buffer size 1024 and sample rate 48000hz.


#2

Do you have any plugins on that track?


(Martin Bruset Solberg) #3

No, this problem occurs even if I start a new project with one single audio track, connected to the inputs, with no plugins on it.


#4

Is there also a click when no input is coming in? Can you record it? Short glitches when looping are normal. In the preferences there’s a seamless loop option which prevent the glitch sound, but when using midi you might run into other issues when activating this.


(Martin Bruset Solberg) #5

There is no sound when no input is coming in. I am not able to reposition the playhead while recording, so I am not able to record the noise.

I recorded in Audacity while generating the noise (moving the playhead around in Ardour with signal coming through the input. The noise was not recorded in Audacity.


(nomusicmore) #6

If the noise didn’t register with Audacity, doesn’t that mean it’s a Jack issue?


(Robin Gareus) #7

Does it also happen when you use Ardour’s ALSA backend (no JACK)?

Do you use JACK transport – that may explain the issue, but since you mention looping you probably don’t use it.

How do you hear any input at all in those cases?

Looping: Ardour rolls, you hear audio from disk ; auto-return: ardour transitions from playing to stop and changes monitoring (that may click). manual reposition… while playing or while stopped?

What monitoring options do you use? auto-input enabled [1], tape-machine mode[2] disabled and Ardour set to do monitoring [2] without a manual override of In/Disk in the mixer?

Can you make a screenshot of the mixer-window, that may shed some light on the track monitor options; perhaps add a-inline scope, a-inline spectrogram plugins to the mixer-strip to show the signal.

[1] Session > Properties > Monitoring
[2] Preferences > Signal Flow