playhead not following

Hello folks,

I’m using Ardour 3.2. on linux mint 14. My problem is the playhead: it moves but the view of the project is not following the playhead. Neither scrolling, nor ‘pagewise’. Even though Strg+F is activated, the playhead just runs out of the right side of the view without scrolling of turning the view of the session.

This is very annoying as I have to follow the session manually with the little left-right arrows next to the ‘summary’ field on the bottom of the screen.

With Ardour 2.8, which I used before on this computer, the view was following the playhead just fine.

Is there something I am missing now?

Thanks Leatuspenguin,
“Have you tried going to keybindings>editor>follow playhead and making sure the keybinding is set to that or to chance it to something else that you can use?”

Yes I changed it to from ‘Ctrl+F’ another one - not difference. Besides: in the “Transport” menu “Follow playhead (Ctrl+F)” is ticked.

One thing I found out thanks to your advice:

If ‘follow playhead’ is not activated and I play the song, then the playhead runs out of view to the right. So far so bad. But pressing ‘ctrl+F’ now, switches to the playing playhead. But then the playhead runs out of view again. When I now press ‘ctrl+F’ the follow-function is deactivated and pressing it now for a third time, the view turns to the new position of the playing playhead.
So if I keep ‘Ctrl+F’ pressed all the time during playing (hence turning ‘follow playhead’ on and off very quickly) the session view scrolls pagewise all the time. Seems like a temporary work around.

it was never a problem in ardour 2.9, but from the first time I used ardour 3.2.

AND: Thanks for the hint with deleting the config-folder! - Now the view follows the playhead again. Whohoo! Great! Thanks a very lot!

uh, short pleasure. not working anymore :frowning: after deleting the config-folder again I realized it just works only the first time after deleting this folder.

thanks for the advice with IRC. I’ll go ask there.

thanks to las and seablade_mbp on irc a solution has been found:

The session “nicetune.ardour” where the playhead doesn’t scroll the view to the right has been started in Ardour 2.8. There the playhead was set to “stationary playhead” ( Ardour 2.8 menu: “transport -> stationary playhead”). This very setting (stationary-playhead=“yes”) was saved in the instant.xml of the session under Ardour 2.8. When I opened “nicetune.ardour” in Ardour 3.2. this setting caused the playhead to not scroll there.

After turning this setting to stationary-playhead=“no” in the coresponding /nicetune/instant.xml file and saving the very file, my playhead scrolls again just like a young polar fox over icelandic glaciers =)

BTW: In Ardour 3.2. there is nothing to check or uncheck “stationary playhead” anymore.

Thank you all for fixing this problem.
I edited all my instant.xml files and it works perfectly.

But the function “stationary playhead” in Ardour 2.8 was very useful.
This function should be integrated in the actual Ardour-version again.

I believe it is on the list, but very graphics intensive, and not very high on the list, so it is not likely any time soon.