Playback Mute Toggle Not Muting

Hello all, first post here.
I am running Ardour ver 2.8 on Debian Sid and it works very well except for the mute function.
When replaying recorded tracks the ‘mute’ button has no effect as i can still hear the track regardless. ;-<
Strangely though, the ‘solo’ function works fine. A clumsy solution is to ‘solo’ all tracks expect the desired mute track… Not too great…
I’ve tried all manner of patch connections using Qjackctl and jack.
My integrated Realtek HDA sound works fine generally with no obvious issues.

Is this a bug? Any help appreciated. :slight_smile:

Right-click on the Mute button on the track and make sure all four options (especially Main outs [or whatever it’s called]) are ticked.

Thankyou peder. That was driving me crazy!
Problem solved. I selected ‘main outs’ and all is now well :smiley:
Maybe a default option should be in place for simpletons like myself. Lol.


The default is to have it selected, so I guess you’ve inadvertently unselected it at some point.

Interesting thought…
To check my sanity I decided to move my .ardour2 profile folder and rename it, so that Ardour would start in a default state.
It appears that (in Debian at least) that by default no muting is selected at all.
Good news for my sanity but maybe not the Debian package. :wink:

OK, I always compile my own version so that’s probably why I haven’t encountered that problem.

To double check you can locate ardour_system.rc (probably in /etc/ardour2) and see if it has ’ <Option name=“mute-affects-main-outs” value=“no”/>’. It should be value=“yes”

Ok, now it gets really interesting. I checked that conf file as suggested and it had the following lines:-
Option name=“mute-affects-pre-fader” value=“yes”
Option name=“mute-affects-post-fader” value=“yes”
Option name=“mute-affects-control-outs” value=“yes”
Option name=“mute-affects-main-outs” value=“yes”

This would suggest that no issues with muting should occur. It seems that for some
reason these entries are being ignored, as running Ardour from terminal outputs the message:- " loading system configuration file /etc/ardour2/ardour_system.rc ".

Seems very strange. When I right click on the mute button no options are ticked, until I check them myself, as previously posted.

Anybody else out there running Debian Sid want to confirm this?

my fresh install of ubuntu studio 9.10 had the same issue

Thank you very much!! I just tested Ardour with my fresh install of Ubuntu Desktop 9.10 and I experienced the same problem. I wasted about 1 hour comparing everything between old projects and a newly created project (the problem does not occur with my older projects) and it was driving me nuts. It would have been better to read here first. :wink:

The version in the ubuntu package is 2.8.2 (5396). Is it worth to place a bug report or is this fixed in newer versions already?

6string, you need to change it in your own directory (i.e. /home/yourusername/.ardour2/ardour.rc).
Unfortunately, this will only make it the default for new projects; for anything you’ve created before you’ll need to set the mute to the main outs.
I had the same problem, really annoying…

Hi there. I have the same problem here on an Arch Linux install.
The values in system rc are all “yes”, the ones in home are all “0”; when I change them to “yes” and start a new project, no mute available. And even when I return to ~/.ardour2/ardour.rc I find it in its initial state with all values to “0”; so Ardour seems to write some defaults back into the config…

I can confirm that no mutes are enabled by default (at least when I compile 2.8.6 myself). Where would one change such a thing in the source (to prevent the package I make from confusing any new users).

Same thing on AV Linux 3.1 - not set by default. Thanks for the info.


The AV Linux Ardour packages are from the Debian pkg-multimedia team, the best way to get this looked at is to report this bug to Debian using the bugreport app in AV Linux.