Playback in loop mode causes pops (start and end of loop region)

Hi, as you can see & hear there are pops at the start of end of loop
(in case you do not notice - at 0:50 you can see and hear pops in the master fader)

the option from screenshot does not help:

my goal is to create midi track > bounce to audio (stem export) and to be able to perfectly cancel with original track. (i’m not thinking about plugins which have variations in reproduction) This refers only to plugins which are consistent in midi playback - no audio changes between each loop iteration…

Any ideas? Thanks

So the audio cancels perfectly with the synthesized MIDI, except at region boundaries where the audio-track fades (as per your preference), but the MIDI does not.

I expect it will cancel perfectly when you disable Loop Fades. Those only apply to Audio. MIDI data never has any discontinues at loops that would require fades).

Hi, Robin
i’ve tried with all options, no luck, as shown in this video:

my personal thought is that audio fades cause this… not sure if they are truly deactivated :smiley:
sidenote: if you deactivate fade out in active looping - it will nudge region playback - as you can hear at 0:20

i can confirm - i duplicated 2 midi tracks - inverted polarity on one - they null out completely, no pops
i duplicated both renders of one midi track - they null out without pops, but when nulling audio with midi - it has pops

Have you also disabled region-fades? (Session > Properties)

as you can hear and see - declick only when transport stars and stops - removes initial pop
the pop in the beginning is not audible when loop is disengaged - but click at the end is audible no matter what… also - stopping playback in middle of auditioning can ‘appear’ not ideal, as on stop - it causes one track to stop playing abruptly whereas other is still playing - and at the very stop - you can hear only one track playback - instead of completely nulling - even when stopping…
take a look:

to rule out plugin - i’ve made experiment with generic midi instrument:

To investigate further: Does it help if you extend the loop region at the end (and/or start), so there is a bit of silence there?

Also, what is your actual goal here?

this is my goal (i can provide example in other DAW if unclear)

increasing loop range - creates even more inconsistency by phasing out audio… (messing with region or engine timing, you are part of dev team - you have better knowledge, i’m just guessing)

if this is not a bug, (that on every next iteration audio is randomly phased) then be it. Analog mojo :slight_smile:

I had a hunch that the slight click you hear in pt5 might be caused by something other than region or loop fades. Your pt6 video confirms that.

Current hunch is that this may be due to the loop range markers being in music-time (rather than sample-time for audio) – right-click on the loop marker, uncheck “Glue to Bars and Beats”.
The bug may rather be related to looping.

Does it cancel when you play normally (no loop)?
Does it cancel when you load the bounce audio into a Clip Slot?

Your testing is very appreciated, we will have to get this right eventually. I am still busy with v7 release fallout, and cannot dive into this specific issue myself at this point in time.

  • loop fades off + unchecked ‘glue bars and beats’
  • play without loop enabled

comparing to looped audio from cue page appears to be the same:

no worries, take your time, i’m not in any sort of rush… i rarely get time to make music these days :smiley:
let me know what else can i do :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.