Playback garbled after moving regions with Ripple-Mode

It doesn’t stay garbled forever. It’s like it has to re-cache after moving all those regions. It stays garbled longer when there are a lot of regions being moved. Is there a way to avoid this, so that I can edit quicker, instead of having to wait 15seconds after each edit before I can test play.

I’m on windows 10, Ardour 6.6.0.

Hmm first I have heard of that. What is your playback buffer set to out of curiosity?


256 samples
96 kHz sample rate

Playback buffer is a bit different, those are your audio device settings. Playback buffer is in the preferences.

See under ‘Audio’

Ahhh, well I was on medium (10), so I tried small (5), and now I’m going to try large (20). See what happens!

Nope. No difference. :cry:

And now it crashes with “Gui pool out of memory. Recompile with larger size!”

Odd, no good answer there. Does this happen with a brand new session?

1 Like

Well, I tried just that. I made the audio settings the same… except for the 256 sample buffer size. I upped it to 1024. It is absolutely flawless now! omg it’s wonderful! So responsive!

Now I’m trying to figure out how to change my previous session to that new buffer size, it seems to want to stay on 256 samples.

Thanks for the help :grinning:

You should be able to open the session, Window>Audio/MIDI Setup, and stop the audio server, change the buffer size, and restart it again. That should do it.

1 Like

That’s what I thought too! I can stop it, I can start it, but I cannot change it.

I DID manage to change it by leaving Ardour open when I had my NEW session running, and then going file > open > original session.

I still get the stuttering for several seconds after ripple-moves. So I think the next step might be to try and export the old session data, into the new session somehow…

Could you try a build (6.6.173 or later, demo is fine for testing). That should fix this issue.

1 Like

Downloading NOW! Thanks for the link, I actually looked for a pre-release version, and couldn’t find it. Now I have!

SOLUTION (if anyone is searching for one in the future)

I have now solved the issue where Ardour 6.6 was stuttering after Ripple-Moves.

  1. Session > Cleanup > all the options
  2. Session > Save-as > new folder / location
  3. I then restarted the PC, but I doubt that was needed
  4. open the new session
  5. window > audio connections: reconnect “Ardour Tracks” to “Destinations”

I am now running it perfectly with an audio device buffer of 64 samples (even lower latency than before, not that latency is important with this edit)

Related Gotcha and Solution

If anyone is having trouble changing the Audio Setup > Buffer size (like me)…

  1. Stop the audio server.
  2. Flip to a non ASIO audio device.
  3. Set desired buffer size on that.
  4. Flip back to ASIO and hopefully the new buffer size remains.
  5. Start the server!
1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.