playback choppy chunky

I 'm totally new to Linux and Ardour, but I 'm having problems with playback in Ardour 2.3. Playback is all choppy and chunky. I’m using Ubuntu 8.04 and my onboard ac97 sound device.

can anyone help me

thx, onno

thx pablo but itś still not working properly. Playback in hydrogen was choppy as well. I can switch the interface in jackd and then it’s working properly. But in Ardour audio setup I can only choose one interface.
don’t know what to do now

I don’t know how to help you.
Show the output of /cat proc/asound/cards. Just in case:
In a terminal: ~$cat /proc/asound/cards > Desktop/audiocards.txt
Copy and paste it here.
Also, before you open ardour or hydrogen, launch qjackctl and post the messages.
Could it be you have to change to period/buffer=3 ?? Just guessing
Cheers
Pablo

here’s the output

~$ cat /proc/asound/cards
0 [IXP ]: ATIIXP - ATI IXP
ATI IXP rev 2 with ALC658D at 0xfe02a000, irq 20
1 [SAA7134 ]: SAA7134 - SAA7134
saa7134[0] at 0xfdcff000 irq 19

messages from qjackctl

14:28:52.081 Patchbay deactivated.
14:28:52.261 Statistics reset.
14:28:57.731 Startup script…
14:28:57.734 artsshell -q terminate
14:28:58.179 Startup script terminated with exit status=256.
14:28:58.180 JACK is starting…
14:28:58.181 /usr/bin/jackd -dalsa -dhw:0 -r48000 -p1024 -n2
jackd 0.109.2
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
14:28:58.214 JACK was started with PID=8865.
loading driver …
apparent rate = 48000
creating alsa driver … hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 32bit little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 32bit little-endian
ALSA: use 2 periods for playback
**** alsa_pcm: xrun of at least 0.016 msecs
**** alsa_pcm: xrun of at least 0.015 msecs
**** alsa_pcm: xrun of at least 0.014 msecs
**** alsa_pcm: xrun of at least 0.015 msecs
**** alsa_pcm: xrun of at least 0.016 msecs
**** alsa_pcm: xrun of at least 0.015 msecs
**** alsa_pcm: xrun of at least 0.016 msecs
**** alsa_pcm: xrun of at least 0.014 msecs
**** alsa_pcm: xrun of at least 0.015 msecs
**** alsa_pcm: xrun of at least 0.015 msecs
**** alsa_pcm: xrun of at least 0.014 msecs
**** alsa_pcm: xrun of at least 0.022 msecs
**** alsa_pcm: xrun of at least 0.016 msecs
**** alsa_pcm: xrun of at least 0.020 msecs
**** alsa_pcm: xrun of at least 0.022 msecs
**** alsa_pcm: xrun of at least 0.023 msecs
**** alsa_pcm: xrun of at least 0.018 msecs
**** alsa_pcm: xrun of at least 0.014 msecs
**** alsa_pcm: xrun of at least 0.014 msecs
**** alsa_pcm: xrun of at least 0.024 msecs
**** alsa_pcm: xrun of at least 0.029 msecs
**** alsa_pcm: xrun of at least 0.017 msecs
**** alsa_pcm: xrun of at least 1.766 msecs
**** alsa_pcm: xrun of at least 0.017 msecs
**** alsa_pcm: xrun of at least 0.029 msecs
**** alsa_pcm: xrun of at least 0.027 msecs
**** alsa_pcm: xrun of at least 0.015 msecs
**** alsa_pcm: xrun of at least 0.025 msecs
**** alsa_pcm: xrun of at least 0.023 msecs
**** alsa_pcm: xrun of at least 9.078 msecs
14:29:00.408 Server configuration saved to “/home/onno/.jackdrc”.
14:29:00.410 Statistics reset.
14:29:00.420 Client activated.
14:29:00.424 JACK connection change.
14:29:00.482 JACK connection graph change.
14:29:00.484 XRUN callback (1).
**** alsa_pcm: xrun of at least 0.022 msecs
**** alsa_pcm: xrun of at least 0.042 msecs
**** alsa_pcm: xrun of at least 0.022 msecs
**** alsa_pcm: xrun of at least 25.365 msecs
**** alsa_pcm: xrun of at least 19.881 msecs
**** alsa_pcm: xrun of at least 7.646 msecs
**** alsa_pcm: xrun of at least 3.528 msecs
**** alsa_pcm: xrun of at least 0.027 msecs
**** alsa_pcm: xrun of at least 0.553 msecs
**** alsa_pcm: xrun of at least 1.748 msecs
**** alsa_pcm: xrun of at least 0.578 msecs
**** alsa_pcm: xrun of at least 2.954 msecs
**** alsa_pcm: xrun of at least 1.611 msecs
**** alsa_pcm: xrun of at least 0.776 msecs
**** alsa_pcm: xrun of at least 3.829 msecs
**** alsa_pcm: xrun of at least 2.786 msecs
**** alsa_pcm: xrun of at least 0.752 msecs
**** alsa_pcm: xrun of at least 1.702 msecs
14:29:01.018 Client deactivated.
14:29:01.019 JACK is stopping…
**** alsa_pcm: xrun of at least 1.524 msecs
jack main caught signal 15
no message buffer overruns
14:29:01.136 JACK was stopped successfully.
14:29:01.137 Post-shutdown script…
14:29:01.138 killall jackd
jackd: er is geen proces afgebroken
14:29:01.554 Post-shutdown script terminated with exit status=256.

  1. Have you checked there isn’t an IRQ conflict, as explained in the link above?

  2. Try period/buffer=3 (I don’t really know if this setting applies to your card, just trying)

  3. Increase the frames/period value step by step, until you don’t get xruns.

I hope this helps
Pablo

But in Ardour audio setup I can only choose one interface.

You don’t need to use ardour’s audio setup. it only pops that up in case jackd isn’t running already, so you may want to launch jackd first, possibly through “qjackctl”, with the correct settings, and then start ardour

http://www.linuxjournal.com/node/1000262