Pipewire drive me crazy help me!

Hi to all of you on the forum,

I’m trying to use Ardor 8.4 with Kubuntu 23.10 but I still can’t figure out how to get Pipewire to work.

Let me explain: in previous versions of Ubuntu that didn’t use Pipewire, using Pulseaudio bridged with Jack was child’s play and everything worked fine and I never had any problems.

Now when I launch Ardour, whether I select Alsa or Jack or Pipewire, I have neither inputs nor outputs or, at best, truly distorted audio.

I tried to follow all the guides I found but the result is that my pro audio system simply doesn’t work and I’m confused…

Could you kindly give me some advice on how to configure Kubuntu 23.10 so that I can start using Ardor again like I did before Pipewire arrived?
I’m running Ardor 8.4 with a Beringher Uphoria 204HD sound card.

Thank you in advance for your patience

In the CLI, these commands before you start Ardour. This will temporarily disable pipewire and pulse audio until reboot.

systemctl --user stop pipewire.socket
systemctl --user stop pulseaudio.socket
systemctl --user stop pulseaudio.servic

1 Like

Thank you Schmitty2005

now the audio works, midi ports not but i can hear the GM synth without latency with my mouse over virtual keyboard.

When i use the commands you show me in the exact order, this is the the output of cli:

maurizio@maurizio-ESPRIMO-P910:~$ systemctl --user stop pipewire.socket

maurizio@maurizio-ESPRIMO-P910:~$ systemctl --user stop pulseaudio.socket
Failed to stop pulseaudio.socket: Unit pulseaudio.socket not loaded.

maurizio@maurizio-ESPRIMO-P910:~$ systemctl --user stop pulseaudio.servic
Failed to stop pulseaudio.servic.service: Unit pulseaudio.servic.service not loaded.

Seems like only the first command is needed

What does amidi -l (lowercase L) show in the terminal ?

1 Like

You may find it beneficial to use the ubuntu studio addons, which feature pipewire configuration tools.


1 Like

I sincerely thank you all for your precious help and for dedicating your time to me but for now I’ll leave Linux alone while waiting for a some new developments of Pipewire, waiting for the new versions that are about to arrive of Ubuntu and its derivatives and other distros.
I’ve tried also Ubuntu Studio 23.10 but, no, no way to use any pro audio software in a reliable way.
I will continue to use Ardour on MacOs Catalina where it works great and without any problems.

The version of Pipewire included in Ubuntu 23.10 is unfortunately not very good for pro audio, so you should wait for 24.04 which will include Pipewire 1.0.x.
However, you do not need to use pipewire: just tell Ardour to grab the Alsa interfaces directly and it will work fine.

1 Like

Thanks guys for your help, really appreciated.

I admit I’m quite stubborn…

And so I wanted to give it another chance to see how Ardor 8.4 works with Pipewire on Ubuntu 23.10 (the standard version).

I first installed all the Pipewire packages (including pipewire-jack), then from the Debian ppa I updated to the latest version of Pipewire and now Ardour works very well.
I still don’t know what exactly I went to configure apart from the real time permissions for audio but in fact everything seems to be working properly now.

I will investigate further to better understand how Pipewire works since from now on it will be the default sound server of almost all outgoing distributions.

Mau65, maybe you should not use the Digital Stereo Profile? Just a guess. If not, maybe the PipeWire Wiki FAQ will help. Explanation follows.

Did you RTM? Admittedly, that’s always a research project great or small as the case may be for Gnu/Linux (my tribute to Richard Stallman). I found that I had to understand the configuration better, which turned out to be simply using correctly the GUI control interface of pavucontrol, which is familiar if not known by name. I expect you use it all the time. However, with PipeWire, the pavucontrol is a front end to the PipeWire implementation of PulseAudio (as I understand it, it’s been a while). On a Debian-like system: ‘apt show pavucontrol’ and ‘apt show pipewire-pulse’.

I am guessing you need to change your understanding of pavucontrol for PipeWire because new options. The definitive documentation for PipeWire’s PulseAudio is at: https://gitlab.freedesktop.org/pipewire/pipewire/-/wikis/Config-PulseAudio . But that might not help you until you have more advanced needs. Expect things to work ‘out of the box’ before slogging through configuration files. You’re welcome.

Take a look at the PipeWire FAQ of the same portal. Specifically, “What is the Pro Audio Profile?”, FAQ · Wiki · PipeWire / pipewire · GitLab .

In my case, if I recall correctly, this was a pertinent gotcha I had to reverse:>

The Digital Stereo Profile is meant to send uncompressed stereo and compressed surround formats such as AC3, DTS or Dolby Atmos digitally to a receiver to be decoded by the receiver. It bypasses part of the mixers in the hardware and makes the digital signal available for receiver with either a coaxial S/PDIF cable, an optical S/PDIF cable or an HDMI cable. If you do not have a receiver that can decode these streams, you should use the Analog Stereo profile to get better mixer controls.

Maybe something else in the PipeWire’s Wiki’s FAQ will help you. I found that it is well written. The problem is the PipeWire does everything, which of course is the solution. Moar options. Moar power. Moar metaphorical rope. I realize how dense today’s software interfaces are and it intimidates me. Good luck!

Thank you very much abyss for your patience and for your explanations, really appreciated.

I’ve to learn a lot about Pipewire.

I think it’s fairly new, I’m not a Linux guru (but a Windows one :wink::joy:).

I need some time to learn in Pipewire what I have learned with Pulseaudio and Jack (bridged or not).

1 Like

Maybe you also need pipewire-pulse.

1 Like