Piano roll draw mode Bar with Auto (possible bug)

When in Piano Roll draw mode, if you select “Bar” and then select “Auto” Does this perform as expected?
Also when you have “Snap” mode on and you click on a veritcal line, the notes get added to the left side instead of the right of the line.
Just wondering if someone could confirm if this is correct.

Hope this helps
Thank You

In Draw-mode, if you select Snap, Bar and Auto, lots of things don’t perform as expected.
Clicking on a bar-line indeed places a note before the bar. And clicking on a place between bars it doesn’t do snap at all (probably because you can’t choose Length Bar, don’t know).
So you better not select Snap-Bar (bug?)
If you select snap 1/4 Note it works as expected.

Paul mentioned development of a new pianroll editor. I hope that gives the possibility to chose Length, Channel and Velocity in Edit mode too. I don’t why that is absent now, it’s a bit confusing.

Hello, thank you for your response.
I didn’t know that other stuff with this setting causes issues as well, thank you for pointing this out.
Ah funny you mentioned this, I made a post about this here

Yeah I am not sure about what the new piano roll editor will offer, it sounds like it will be replacing what is currently available completely. I actually like how it is setup overall, so hopefully the changes if anything will be better because it does not sound like there will be an ability to use the current method (toolbar) any longer.
In the link I mentioned above I was just pointing out that maybe commonly used parameters can be made available in the toolbar.
Anyways, thank you again for letting me know about the other issues with the “Bar” mode.

The “new piano roll” will absolutely not completely replace what is available.

I guess we just have to wait for the new piano roll editor and see what it brings. But sound8, it’s good to point out your ideas and also to indicate unexpected behaviour of the software.

It is not intended to bring anything new at all, at least not initially.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.