Permissions change for VST plugin install (probably a stupid question)

I’m running under unbuntu studio with Ardour 7.2.
I need to change permissions with the terminal to ‘‘user’’ to past the .so files.

My VST folder looks to be user/lib/vst

In the terminal Without success with Chown I wrote: sudo chown (the name of my computer) /user/lib/vst. Here the result. ‘‘Aucun fichier ou dossier de ce type type’’

I dont know what i’m doing wrong.
Capture d’écran_2023-01-23_16-48-06

The correct spelling of the system directory is /usr, so /usr/lib/vst would be the directory name to use.

However, you should not change the permissions on directories in /usr. If you want the plugins available for only your user you can place them into a directory within your home directory, or if you want to make the plugins available for multiple user accounts on your computer then use sudo to copy the plugin files, but leave the existing directory permissions.

Not the same result but dont work
Capture d’écran_2023-01-23_18-18-40

I would like to put all vst plugin in the same place but i will try the second solution.

Solved! thank you Chris!

For future reference (but assuming from your comment that you don’t need it now):

  • You need to run chown as a user with current permissions on a file or directory (in your case, either running as the actual root user or via sudo.
  • To change not only a directory but all the files and subdirectories it contains, recursively, you need to pass the --recursive (aka -R) flag.

Not sure to understand, sorry. Can you show please an example of what to it looks like in a terminal please ?

tseaver meant to say:

  • only the current owner of a file/folder can change its ownership via chown.
    As /usr/lib/vst is owned by root, the command has to be run by root. in your first posting/screenshot you ran “sudo …” to achieve that, it fails because the path was wrong. in the second screenshot it doesn’t work because you are not root currently, nor use sudo.
    But please as ccaudle said, changing anything in /usr to be owned by your user is a bad idea.

  • the second hint intended to say that /usr/lib/vst is a directory, and your command would have changed only this folder’s ownership. To include all contained files, it should include the -R/–recursive option:
    chown -R <username> </path/to/folder>

1 Like

Thanks for clarifying, @edogawa.