Performance Issues Preventing Standard Use

I am experiencing intense performance issues related to recording and record-arming tracks in Ardour on Debian 12. I have installed Ardour 7.5.0 using the .run file, though I also tried using the outdated version provided by the Debian repositories.

Various Details:

I am running KDE Plasma on Debian. I am using an nvidia GPU with the latest proprietary drivers in the Debian 12 nonfree repository. I’ve used Ardour in the past on previous systems.

My Issues:

When I hit the button to record-arm, there is a delay of about 30s to a minute before I see the audio level changing indicating that it is ready. Even so, the audio level indicator periodically freezes for significant periods of time. It’s odd because it doesn’t appear to be the GUI that’s hanging since I can do things such as open the Editor Mixer and the log while these issues are happening, and the buttons are still responsive as well. Similarly, pressing the button on the Editor Mixer to monitor input causes a delay and some freezing. When I am trying to record, Ardour is essentially unusable, because the program will stop recording several seconds in and freeze for around a minute when I do so.

What I’ve already tried:

As I mentioned earlier, I have installed Ardour from the Debian 12 repository as well as used the .run file. The only version I haven’t tried to install is the Flathub one, and don’t really want to, since it’s out of date and rumored not to work with JACK. All appear to have the same issue. I followed the instructions on the Debian documentation and edited the limits.conf to prevent Ardour from running out of memory. This did not appear to solve the issue unless I’ve done something wrong. When I type the ulimit command, it displays “unlimited.” I also tried not using JACK, but that didn’t solve the issue either.

Does anyone have a solution to this or know what might be the cause?

Edit: I have not tried the nightlies.

@Skyward9964 Does the delay / freeze happen when you open a new session after stating in “safe mode”? E.g.:

/opt/Ardour-7.5.0/bin/ardour7 --disable-plugins

It may also be worth checking a different video driver (in addition to the plugin check which tseaver recommended). In the past there were complaints about the nvidia proprietary driver, but I do not know if that is still the case. May not be related at all, but just grasping at various things at this point because as far as I know there are no similar problems reported with Ardour.
As far as I know the only option to the proprietary nvidia driver is the nouveau open source driver.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.