Peakfile and Playback Distortion

Firstly, many thanks to all those who’ve worked
on creating and maintaining Ardour!

After using Ardour 0.99.3 without any problems,
I’ve just compiled and installed 2.0beta8 and
am now running into a problem with distortion
on playback with both versions of Ardour. It’s
my guess that the install has overwritten
something used by the old version, or that
they’re sharing some data file somewhere, etc.

Note: recordings made before the recent
installation of 2.0beta8 still
play back without sounding distorted; the
problem is only with data that’s just been

Is there usually a problem with having both
versions installed? If didn’t appear so at
first, since ardour and ardour2 were names
used for binary files and directories created
by the installations.

Back to the distortion: after exiting Ardour,
there were lines in the xterm telling me that
there was a problem reading peak data in
the peakfile. Can someone kindly explain
what that means and what may be causing the
problem with distortion?

Happy new year!

Sounds like a weird problem. Try the latest beta, or the current SVN version. There has been a lot of work on peakfiles lately.

There shouldn’t be any problem having both 0.99.3 and a 2.0 beta version on one system. Just keep in mind that once you open a session with 2.0, 0.99.3 can’t open it anymore.

Hi, Happy New Year!

Thanks, I downloaded and compiled 2.0beta 9 and the distortion problem went away. However… when I first
tried v2b9, there was no problem with
recording. After several minutes of
recording, and restarting Ardour, the recording kept getting interrupted with messages about the disk not being fast enough for Ardour and then message about the system not being fast enough. There are also frequent crashes and lengthy hangs which lock up the system for a few minutes.

I’m getting about 200MB/s throughput with the disk being used, and the system has an 800MHz CPU, so that should surely be enough for recording
two tracks. There’s nothing else running but qjackctl and two xterms,
and the fvwm window manager. The realtime module is loaded with any=1 and allcaps=1.

When ardour2 is started, the response
with the mouse is very sluggish and lots of delays. This wasn’t a problem with 2.0beta8, to the point where I’d get any messages about system performance being insufficient, or to cause crashes and hangs, although 2.0beta8 was less responsive than 0.99.3, which is now also giving me error messages about not being able to read from the peakfile.