OvertoneDSP plugins

I have just tried two of these VST plugins, the FC70 and the PCT-2A in demo mode. They worked and I think they could be useful to me. However, it was not possible to re-open the Ardour project with the demo plugins installed. Indeed before I could open it, I had to rename the VST .so files. I contacted OvertoneDSP and they said that this behaviour was not an intended feature of the demo mode. Further they said, “Its possible that the demo splash screen is triggering some bug in Ardour, in which case using the unlimited version might fix the issue, however we would not recommend purchasing an activation key if you cannot be sure the plug-in will be compatible with your host application”. Adding, “We consider Ardour to be Beta software at the present time, and as such we are only able to undertake limited compatibility testing with it”.

I was somewhat disappointed. I wonder if anyone out there uses any of the OvertoneDSP VST plugins and if purchasing the key solve the problem encountered by me?

I am running Ubuntu Studio 16.04 and Ardour 4.7 and I find it very stable indeed.


@paul: I haven’t yet checked the possibility of using a plugin host (looks like Carla would be the one) in conjunction with Ardour/Mixbus. I would agree that if this kind of setup provides enough decoupling so that plugins can crash w/o affecting the DAW, then yes, a solution would be there. The 80% you mention implies a grey zone of some sort. I will definitively check it out. This is possible to do for us, as we compile stuff already. I mean, we can eventually figure out how to make it work, as I’m almost certain this setup is not brought to functionality w/o some rough corners that needs to be investigated/asked about. But that’s OK. I agree with this kind of setup and the Ardour resources available, makes common sense.

For common folks, the Bitwig approach provides an integrated way of having this.

I use several of them, all licensed, and don’t have any trouble with them, but I have on occasions opened Ardour with an unlicensed OvertoneDSP plugin and not had the problem you are describing either, so I can’t promise your particular problem would go away if you purchased an activation key.
(New AV Linux 64 bit, previously AV Linux 6.04 32 bit).

I have done a little more investigation. The problem seems to be associated with running the OvertoneDSP plugins alongside Pianoteq. I started a new Ardour 4.7 session and loaded the two Overtone DSP plugins. I saved and re-opened the project with no problem. I then tried to add a midi track with Pianotech in it. Ardour crashed immediately. Doing it in reverse order, Pianotech first and then the OvetoneDSP plugins did appear to work and I was able to save the project. However, it would not subsequently open.
dmesg reports the following: ardour-4.7.0[4324]: segfault at 15d79c80 ip 00007f95921f8e1e sp 00007ffe145c2d38 error 4 in libc-2.23.so[7f959215a000+1c0000]
Where does the fault lay, Ardour, one or more of the plugins or elsewhere?

Further: I just tried it in Ubuntu 14.04 and everything works fine. Looking at the libraries in /lib/x86_64-linux-gnu in the two systems, they are different. In 16.04 libc.so.6 is linked to libc-2.23.so and in 14.04 libc.so.6 is linked to libc-2.19.so.

try the gcc5 nightly on 16.04 and i believe your problem will be solved

I have tried the gcc5 version this morning (Ardour_64bit-4.7.993-gcc5.run). I does exactly the same.
I shall give in with OvertoneDSP plugins for now. I tried them on a whim, looking for a magic bullet to give my mixes more life. Some good came of it though; I subscribed to Ardour.
Thank you for you input.


Would be really useful to have a backtrace I would imagine of this. See here…


As of yet not sure where the problem is, one question though, where did you get your copy of Ardour from? It is recent enough I would imagine it is from here, but gotta check.


@dickelec: What you’ve identified could be some kind of gcc4 / 5 wierdness - the OverTone plug-ins are built with gcc4, however I don’t believe we do anything which should trigger compatibility problems on a gcc5 system. The only way to avoid any potential clashes for certain would be to stick to a gcc4 based distro / applications (and as you have already tried, Ubuntu 14.04 appears to work). At the present time we recommend 12.04 - 14.04LTS, and, unless something quite unexpected happens, I don’t envisage we will be releasing gcc5 specific builds of our current linux products.

I got Ardour from the Ardour downloads page on this site. The gcc5 version I got from the nightly builds page. I shall endeavour to generate a backtrace. I only tried the gcc5 version because braxtons12 suggested it may help. I reiterate, both versions produced the same result and only failed when both Pianoteq and OvertoneDSP VST plugins were installed together.

I reiterate, both versions produced the same result and only failed when both Pianoteq and OvertoneDSP VST plugins were installed together.

However you were running everything on a gcc5 based distro (16.04) and when you switched to 14.04 you said the problem went away. In addition, your original email gave the impression that it was entirely an issue with our products:

I have installed the demo of FC70 and PTC-2A on my Linux studio machine (Ubuntu Studio 1604) and tried them out in an Ardour (4.7) project, using the VST version plugins. It worked fine initially but when I tried to open the Ardour project later, it would not open. The demo warnings came up then Ardour bombed out. The only way I could open the Ardour project was to change the VST .so file names.

You made no mention of any other plug-ins. I have outlined the issue to the pianoteq devs, perhaps they will be able to help. What we’ve determined so far is that if you use my plug-ins they work fine, but if you then add the pianoteq plug-in, ardour crashes. My guess is that when you try to open your project, the OverTone plug-ins are instantiated first (and you see their splash screens), then ardour instantiates pianoteq and crashes. Same as when you do it manually. This could also be completely unrelated to either plug-in specifically - it might point to a midi issue with ardour for example.

I just ran Ardour with GDB. Ardour started and I loaded the project with the three VST included. After a few seconds Ardour crashed and disappeared from the screen. Your debugging instructions say that the Ardour display will remain but will freeze. I typed the next gdb command but nothing happened. I’ll give you what did come up.Please give me instructions if you want me to do anything else.

dick@Studio:~$ /opt/Ardour-4.7.0/bin/ardour4 --gdb
GNU gdb (Ubuntu 7.11-0ubuntu1) 7.11
Copyright © 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type “show copying”
and “show warranty” for details.
This GDB was configured as “x86_64-linux-gnu”.
Type “show configuration” for configuration details.
For bug reporting instructions, please see:
Find the GDB manual and other documentation resources online at:
For help, type “help”.
Type “apropos word” to search for commands related to “word”…
Reading symbols from /opt/Ardour-4.7.0/bin/ardour-4.7.0…(no debugging symbols found)…done.
(gdb) run
Starting program: /opt/Ardour-4.7.0/bin/ardour-4.7.0
[Thread debugging using libthread_db enabled]
Using host libthread_db library “/lib/x86_64-linux-gnu/libthread_db.so.1”.
bind txt domain [gtk2_ardour4] to /opt/Ardour-4.7.0/share/locale
Ardour4.7.0 (built using 4.7 and GCC version 4.4.7)
ardour: [INFO]: Your system is configured to limit Ardour to only 65536 open files
[New Thread 0x7fffea1d5700 (LWP 4578)]
ardour: [INFO]: Loading system configuration file /opt/Ardour-4.7.0/etc/system_config
Loading user configuration file /home/dick/.config/ardour4/config
CPU vendor: GenuineIntel
ardour: [INFO]: CPU brand: Intel® Core™2 Quad CPU Q6600 @ 2.40GHz
ardour: [INFO]: Using SSE optimized routines
[New Thread 0x7fffe99d4700 (LWP 4579)]
[New Thread 0x7fffe91d3700 (LWP 4580)]
[New Thread 0x7fffe89d2700 (LWP 4581)]
[New Thread 0x7fffdada8700 (LWP 4582)]
[New Thread 0x7fffda5a7700 (LWP 4583)]
Cannot xinstall SIGPIPE error handler
ardour: [INFO]: Loading default ui configuration file /opt/Ardour-4.7.0/etc/default_ui_config
ardour: [INFO]: Loading user ui configuration file /home/dick/.config/ardour4/ui_config
ardour: [INFO]: Loading colour file /opt/Ardour-4.7.0/etc/dark.colors
ardour: [INFO]: Loading ui configuration file /opt/Ardour-4.7.0/etc/clearlooks.rc
ardour: [INFO]: Loading ui configuration file /opt/Ardour-4.7.0/etc/clearlooks.rc
[New Thread 0x7fffd8efa800 (LWP 4584)]
[New Thread 0x7fffd8c6e700 (LWP 4585)]
[New Thread 0x7fffd87e3700 (LWP 4586)]
[Thread 0x7fffd87e3700 (LWP 4586) exited]
[Thread 0x7fffd8c6e700 (LWP 4585) exited]
[New Thread 0x7fffd8c6e700 (LWP 4588)]
[New Thread 0x7fffd87e3700 (LWP 4589)]
[Thread 0x7fffd87e3700 (LWP 4589) exited]
[Thread 0x7fffd8c6e700 (LWP 4588) exited]
[New Thread 0x7fffcab89700 (LWP 4590)]
[New Thread 0x7fffc9f73700 (LWP 4591)]
[New Thread 0x7fffc9772700 (LWP 4592)]
[New Thread 0x7fffc8f71700 (LWP 4593)]
[New Thread 0x7fffbffff700 (LWP 4594)]
[New Thread 0x7fffbf7fe700 (LWP 4595)]
Found nothing along /home/dick/.config/ardour4/templates:/opt/Ardour-4.7.0/share/templates
run dialog
[Thread 0x7fffbf7fe700 (LWP 4595) exited]
[Thread 0x7fffc8f71700 (LWP 4593) exited]
[Thread 0x7fffc9f73700 (LWP 4591) exited]
[Thread 0x7fffbffff700 (LWP 4594) exited]
Announcement is:
[Thread 0x7fffd8efa800 (LWP 4584) exited]
[New Thread 0x7fffd8c6e700 (LWP 4596)]
[New Thread 0x7fffd87e3700 (LWP 4597)]
[New Thread 0x7fffc8360700 (LWP 4598)]
no more csLADSPA plugins
Scanning folders for bundled LV2s: /opt/Ardour-4.7.0/lib/LV2
[New Thread 0x7fffbffff700 (LWP 4600)]
[Thread 0x7fffbffff700 (LWP 4600) exited]
Set cursor set to default
[New Thread 0x7fffc818c700 (LWP 4601)]
[New Thread 0x7fffc810b700 (LWP 4602)]
[New Thread 0x7fffc808a700 (LWP 4603)]
Set buffering params to 262144|131072|10|10
[New Thread 0x7fffbce5b800 (LWP 4604)]
[New Thread 0x7fffbffff700 (LWP 4605)]

ACMT-UI: UI text - Using UTF-8 encoding
[New Thread 0x7fffbf7fe700 (LWP 4606)]

** FC70 VST Running in DEMO MODE:-
Every 60 seconds, the audio will
fade to silence momentarily.

ACMT-UI: UI text - Using UTF-8 encoding
[New Thread 0x7fffc9f73700 (LWP 4607)]

** PTC-2A VST Running in DEMO MODE:-
Every 60 seconds, the audio will
fade to silence momentarily.

[New Thread 0x7fffc8f71700 (LWP 4608)]
ACMT-UI: UI dpi 95
ACMT-UI: UI scale 100.0 %
ACMT-UI: UI dpi 95
ACMT-UI: UI scale 100.0 %
ardour-4.7.0: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
ardour-4.7.0: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
warning: Probes-based dynamic linker interface failed.
Reverting to original interface.

Cannot access memory at address 0x7fffffff8f88
(gdb) [Thread 0x7fffc8f71700 (LWP 4608) exited]
[Thread 0x7fffc9f73700 (LWP 4607) exited]
[Thread 0x7fffbf7fe700 (LWP 4606) exited]
[Thread 0x7fffbffff700 (LWP 4605) exited]
[Thread 0x7fffbce5b800 (LWP 4604) exited]
[Thread 0x7fffc808a700 (LWP 4603) exited]
[Thread 0x7fffc810b700 (LWP 4602) exited]
[Thread 0x7fffc818c700 (LWP 4601) exited]
[Thread 0x7fffc8360700 (LWP 4598) exited]
[Thread 0x7fffd87e3700 (LWP 4597) exited]
[Thread 0x7fffd8c6e700 (LWP 4596) exited]
[Thread 0x7fffc9772700 (LWP 4592) exited]
[Thread 0x7fffcab89700 (LWP 4590) exited]
[Thread 0x7fffda5a7700 (LWP 4583) exited]
[Thread 0x7fffdada8700 (LWP 4582) exited]
[Thread 0x7fffe89d2700 (LWP 4581) exited]
[Thread 0x7fffe91d3700 (LWP 4580) exited]
[Thread 0x7fffea1d5700 (LWP 4578) exited]
[Thread 0x7ffff7fb08c0 (LWP 4574) exited]
[Inferior 1 (process 4574) exited with code 01]
(gdb) thread apply all bt

ardour-4.7.0: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0. ardour-4.7.0: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
hmm that doesn't look good - normally points to something not playing nicely with X - there are many possible causes, and new ones are being invented all the time. Trying to make reliable plug-in UIs on linux is fraught with problems, mostly due to X11 related nastiness. Here's a taste of (just some) of the issues.


recommended reading for anyone considering developing (plugin) UIs on linux.

…and if that is the problem - I suspect that painoteq is inadvertently doing something which breaks my plug-in(s) connection to the X server - this would explain why if you instantiate pianoteq after my plug-ins there’s a crash, but not if you instantiate pianoteq first. I vaguely remember seeing something like that happen when the video timeline was introduced into ardour, the viewer window was spawned in another process (incorrectly) and it caused some file descriptor confusion and trampled all over my plug-ins in a similar way.

The Q&As are getting out of step here. In answer to mike@overtonedsp: I mentioned in my second post that it only happened when both OvertoneDSP and Pianoteq VST’s were installed together, though I hadn’t realised that to be the case initially. I had added the OvertoneDSP plugins to an existing project and it went wrong. I know nothing of gcc4 and gcc5 other than what has been said in this thread.
The Pianoteq plugin works fine too. I have been using it for some time without issue, including for about a month, on Ubuntu Studio 16.04.
I conclude that the only issue is that I tried the OvertoneDSP plugins on a system they did not support.

I had added the OvertoneDSP plugins to an existing project and it went wrong...
And, from all the other evidence it appears that the plug-ins work, as does the pianoteq plug-in. As you mention, the problem is that they don't work together. I've outlined a possible reason for this, and I've also explained how and why it is that (given that the order in which you add the plug-ins is also important) you can't then open the session (opening the session causes ardour to instantiate my plugins, and then pianoteq, which causes a crash, exactly as it does when you manually add my plug-ins and then pianoteq, for the reasons I've hypothesised). I'm taking time to respond to this issue, not because I think there is anything I can do necessarily to correct it (as I don't believe my code is at fault), but because I care about things working properly, and, also to counter the repeated implied assertions that it is my software which is at fault, which I don't believe to be the case either.

(After far too many years spent (or more likely wasted) trying to make something that I (and hopefully others) could actually use on linux, I admit I’ve grown more than a little tired of getting the blame for other people and / or their applications repeatedly breaking my software).

@ mike@overtonedsp: I know that people usually don’t write mails or comments about software that just work great with now flaws, but for quite some years of studio work i had tons of problems with all kind of plugins MINUS the overtone/linuxdsp ones that I keep using on a regular basis…

Its good to know when the plug-ins work well - (the fact that I was still posting replies to this thread at around 00:30 last night, might be an indication of the commitment I have to making this software work well, on all the platforms we support).
True enough I don’t expect people to tell me all the time that the software is wonderful, and I appreciate that sometimes it isn’t - but, if there are genuine problems I think I / we are responsive to those issues (we don’t get too many support issues, given the number of users - the majority of them are actually people trying to haggle down the price of a £10 plug-in, or needing reactivation codes after they failed to back anything up before reformatting their system). This can however be a fairly thankless task, especially when there are problems which are beyond our control.
The unique problem / challenge for plug-in developers, is that our product(s) have to exist inside of a host application, together with many other developer’s plug-ins, all of which magnifies the opportunities for things to go wrong. Added to that, there are things that make linux uniquely unsuitable for things like plug-in UIs (trying to get embedded X11 UIs to work, is something like juggling with chainsaws, and in this case, while someone then comes along and sets fire to your trousers - and don’t think openGL will save you, it still requires X11 which only makes the situation ten times more complicated / worse).

I think my main concern is that by the time we get to the point I hoped we could reach when I started looking at (desktop) linux as a viable replacement / platform for my own audio projects, around ten years ago, we may (if we haven’t already) have missed the opportunity.

I’m sorry if you think I am trying to ignite your hose or trying to haggle for a lower price. Neither is my intention. In all innocence I asked a question, then I responded as best I could to the follow-ups.

I must say that, despite the minor hurt of the accusation, this thread shows how responsive the Linux community can be to a simple end user. The enthusiasm of the participants is undeniable. I doubt that the main players in this field would have still been considering the issue in the wee small hours. Their lawyers may have been.

As a footnote, if indeed this is the foot, I should say that I have spent a little more time with these two OvertoneDSP plugins ( on Ubuntu 14.04) and I like them. I shall buy the keys.

Thanks to all.

@ dickelec I think he wasnt commenting on you specifically mentioning his support routine…