Outputting to mulltiple output devices windows

I want to monitor the audio through my headphones while also sending that audio to a different output (vb-cable) device. This would allow me to use that signal as a microphone input in obs and voip applications.

I use a new installation with all default settings on windows 11.

My starting audio configuration:
audio setup

Devices I would like to output to.
“speakers (fiio q series)” and "CABLE input (VB-Audio …)

What I would like to do:
Add an external send to the mixer pane (which contains the monitoring channel for the microphone from “master”). I would like to “send” the audio to the vb-cable output device with this, while ardour still sends the monitoring output to my headphones.

My issue is that none of my devices (except for the system output) show up in the routing grid. So I see no way to output to multiple sources.
I also made an accompanying video to show exactly what I mean: Ardour multiple audio output streams - YouTube

I don’t have the slightest clue how I can make ardour recognize my other output (and input for that matter) devices in the routing menu.

Am I misunderstanding the purpose of the routing menu, does ardour on windows not work with multiple devices at once, do I need some external tools,…?

I’m also quite new to the audio processing scene so please correct me if I misuse(d) any technical terms. I’m here to learn.

In general it is a bad idea to use a DAW with multiple audio devices unless they are sync’d and locked together, which is a more complex task than most people deal with.

So short answer is no Ardour doesn’t use multiple outputs devices at once.

1 Like

Alright, thank you for the quick response.

I found a solution for my use-case by using asio4all and vb-cable.
Install asio4all and vb-cable first. Make sure that you set your playback device and the vb-cable output to 16 bit and match the sample rate (in windows settings) to what you set in ardour.
In my case everything’s set to 16 bit 48 kHz.

When you start ardour and get the audio/MIDI setup popup:

  1. Set the driver to asio and the input and output device to asio4 all v2.
  2. Click on “Device Control Panel” on the right hand side and the asio4 all control panel should pop up. (If it doesn’t doubleclick the asio4all tray icon)
  3. In that control panel click on the gear in the right lower hand corner and select the microphone and your output devices (the on button should become white).
  4. If your device has a + icon in front of it, click on that and make sure to only enable the outputs for your output devices and the inputs for your input devices.
    This is what it looks like for me:
  5. Close the asio4all controll panel AND ardour. I don’t know why but closing ardour completely, is necessary otherwise the devices won’t update in the routing menu later on.
  6. Start ardour again, do your audio setup, go to the audio routing panel and now you can route to multiple outputs.

For me this is perfect. Now I can listen to my own voice with very little latency (thanks asio) AND also use that same audio in other applications.

For anyone reading this. I am not a sound engineer or ardour wizard. It is very well possibe that you break your audio setup and I’ll not be able to provide support since I’m just a big dumdum who found a hacky solution for my specific problem. Anyway I hope that by writing this I can help someone out in the future with the same requirement as me.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.