Out of the box Ubuntu Studio Ardour gives weird echo on playback with Behringer interface

Hello there - newbie question:

Just installed Ubuntu Studio on a live usb and am trying out Ardour with my Behringer UMC202HD.

Not tried to record anything yet, but just imported a simple .ogg backing track (Sweet Child o Mine) and was going to jam along with it, maybe try to record some lead over the backing.

When I configure the playback through the speakers/headphones connected to my laptop all is fine, but when I configure the playback to go through the Behringer it has some really weird echo on it…? I have tried fiddling with all the settings under “Audio/Midi Setup” but nothing makes any difference?

Previously I have dabbled iwth Jack as well but it seems Ardour is managing that just fine so not touched it other than to select the audio interface in the settings.

Any ideas what I may be doing wrong or is the Behringer just not very good? (seen some disparaging comments about them online…)

Thanks for helping out a noob.
Sudge.

Well Behringer not being good is only a small part:)

In all likelihood your problem is in the setup of your Behringer, do you have Direct Monitoring on? Try turning it off in that case? I don’t think there is a DSP mixer in that device but if there is that is probably your most likely cause of your issues, checking all routing there would be a good starting point.

Seablade

Yeah Not a fan of the brand, but don’t think that’s constructive at this point. If you are looking at the front of the 202HD, there is a little button near the top right of the unit that is labeled “Direct Monitor”. You have two options here:
1)Keep everything in Ardour the same and turn OFF this “Direct Monitor” option. or
2)Keep Direct Monitor on, but make sure the track you recording to is muted in Ardour. This is helpful if your system has more roundtrip latency than you can deal with while tracking.

Also, in case its helpful: https://media63.music-group.com/media/sys_master/h1f/h9b/8849476255774.pdf

Thanks Seablade and Saam for your swift replies,

I tried out turning off the Direct Monitor switch, and although the volume level changed slightly the echo/reverb was still there through the headphones output, but is fine through the main outputs on the back (had only tried with the headphone jack before).

Then I tried importing the backing track using session > import > [select .ogg file] rather than what I’d done before (which was create a ‘stereo track’ to drag the file onto the editor). Instead of one stereo track I got a pair, which comes out fine from the headphones. However, the odd thing is that in the mixer when I pan the two separate tracks to the left and right they don’t pan in the headphones, they just get louder as it’s moved away from the 50% mark.

I am just trying to figure out if I have some learning to do or this interface isn’t really compatible.

Thanks again
Sudge.

For the record not much difference between dragging and dropping and session > Import. At one point the default settings for drag and drop was to embed rather than copy the source to the session, but that was the extent of the difference and can be changed through Preferences. Not sure if it is still the same default or not. I always set it to copy anyways so it may just be that I am used to my changed settings now.

If it is fine on the master outs on the mixer, that indicates a problem either in your routing from Ardour to the interface, or within the interface, the latter is more likely on a plain session you haven’t modified anything with. It actually sounds like the headphones may be getting a mono output, but to know for sure I would need to know more about that interface and your particular routing.

If you are using jack for the backend (Seems like you are from the OP) can you post up the output of the following command on the command line surrounded by CODE tags?

jack_lsp -c

It will tell me about your routing between ardour and your interface. Thanks

Seablade

If the OP is using headphones with embedded microphone—like the ones for mobile phones with a jack adapter—he has to slightly pull or push the mini jack to match the contacts on the interface (or on the adapter).

2 Likes

Amazing. A little jiggle of the headphones jack did the trick! They are the kind with a mic in because I have misplaced my proper ones - now I will go and find them!

Thank you both so much for your help and speedy replies - you really got a newbie off the starting blocks. I can’t wait to see what I can do with Ardour now…

Cheers,
Sudge.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.