Out of Sync With Metronome?

Used Ardour for years, maybe didn’t notice before but recording e.g. a drum beat in midi to the metronome, the notes are all very slightly ahead of the beat. I tried the calibrate audio test and ‘use results’ - no change. In Reaper and Waveform there is no such misalignment whatsoever using same hardware and plug-ins. Have I missed something in Ardour - (my daw of choice) ?

Could you do a simple test: Record the microphone back to a track. Either using a cable or for quick/dirty test hold a headphone with just the metronome next to the mic and record the click (mute master-bus so you don’t get feedback).

Here it’s spot on (Linux, Ardour/ALSA, USB-soundcard IA-25 48kHz, 1024 samples buffersize)



What soundcard do you use? Which OS? What settings?
Could it be that there have been dropouts after calibrating latency?

Hi Robin

Thanks for your prompt response. Metronome (below) looks pretty good
actually, I only have a cheap UM2 interface and am running Debian 11 with
RT group added etc. Settings are 2 periods 512 samples 11.6ms Latency. When
I record the output of the sound card I get a consistent doubling of the
metronome and played note as shown. Assume the obvious, I’m not very tech
savvy and may have made a simple error :slight_smile: I use a Swissonic Easykey 25 and
have tried an Akai LPK25 to make sure it wasn’t a keyboard problem.

Best Regards

Rob

Have you muted the master-bus?

Otherwise you get:

metronome → soundcard out → cable → soundcard in → Ardour track → Ardour master → soundcard out → LOOP

PS. Alternatively you can also change the track you record onto to explicitly monitor “Disk”:

image

This does not let the input signal pass through. This way you can also re-record MIDI using a loopback.

Thanks for that. Actually it all seems down to the Kernel/Distro/Settings,
I’ve experimented today with Ubuntu Studio live iso, and the problem is
absent. Perhaps Bitwig, Reaper and Waveform handle the audio/routing in
different ways as I cannot create the problem in those environments in
Debian, maybe they’re more forgiving. Thanks again for taking a look at
this and your prompt responses. Some people say that a dedicated audio
distro is essential in Linux, perhaps that’s true.

Regards

Rob

Are you using JACK? If so try without it.

Tech Details

With USB devices there is a known problem: Every time jack starts the latency is slightly different. So calibrating latency correctly is not possible with USB devices.

This is due to how the linux kernel manages USB audio.

Ardour/ALSA (no jack) does not have this issue, since the device remains in use after calibration.

Recent Linux kernel 5.16 mitigates the issue, but it is not yet in debian.