OpenColor based Ardour color theme

Hi all,
some months ago I started doing a bit of experimentation on theming different FLOSS Linux audio applications and plugins using the OpenColor color scheme (GitHub - yeun/open-color: Color scheme for UI design.).

I just updated and fixed some minor things in the Ardour color theme, any suggestion is welcome.

You can download it here: LAM / AudioThemes · GitLab

Cheers

8 Likes

Hi there. Thanks for the work on this. I’m not clear on whether or not you consider this to be a “bug fix” for the default ardour theme, or whether you consider a new theme.

Hehe! :grin:
I was referring to my theme, to be considered as a new one.
I worked on it more than six months ago and I updated some minor things to make it play nice with 6.9, plus some minor changes.

Hi LAM: I like that. So I guess I have to download xcolors-ardour.colors and save it into the /themes folder. How can I then activate it in Ardour?

regards
Michael

Hi, glad you like it. :slight_smile:

To use it you have to go in Edit > Preferences > Appearance > Colors, and select Xcolors from the Color Theme dropdown menu.

I personally love this theme and think it would be great if Ardour included it by default. Even used it by default, I dare say! But I would settle for mere inclusion. :grinning_face_with_smiling_eyes:

2 Likes

I love it! However I believe there is a minor bug (let me know if you want me to file it on GitLab). In the Recorder interface, the “Duration”, “X-runs”, and “Remaining Time” widgets come up with random colors (Remaining Time actually cycles through colors).

You need to start Ardour with this Theme in place in order to see it, otherwise I believe it picks up the colors from the previously loaded Theme.

I don’t know anything about theming, but I vaguely seem to recall @x42 once mentioning this happens when a tag is left undefined (or something like that). Perhaps he or @cooltehno can point you in the right direction.

Otherwise, awesome, I think these will be my new colors.

-Manuel

Good catch! Thank you, I will look into this.

Should be fixed now! :slight_smile:

You recall correctly. If a color is not defined, Ardour assigns a random one every time the item is rendered. This makes it very obvious that a color is missing in the theme.

We call this harlequin debugging :slight_smile:

3 Likes

That’s it! I couldn’t remember what it was called to search for it, but at least I remembered who said it :wink:

Thanks

Yup! Excellent! Well done. Looking forward to checking out the others.

1 Like

I must say that I’ve always been very impressed with Ardour’s default theme (and UI design). Often times developers are not very good in designing a good UI, but I think Ardour is an exception (in my very humble opinion – I am not an expert at all, just a user). I think it looks great out of the box: clear, with good contrast, easy to see and spot all parts… Kudos to the team! So far, I never felt the need to try different themes.

That being said, I really like this theme. Maybe it’s just the different/new factor, but I will stick with it for a while, I think. Thanks for sharing your work!

4 Likes

I’ve fixed some more colors in the Rec view, didn’t test while recording. :stuck_out_tongue:

1 Like

Very cool theme. i hope that included on ardour tree to get mantained for new versions!
thanks for sharing

Very nice theme. However, the “No Align” warning blinks. It’s annoying because sidechain connections will prompt the warning when it is not really a problem. Under other color schemes the “No Align” merely lights up.

Hi,
probably you’re referring to the foreground color, the color of the “No Align” text.

The background (red) is “blinking” in the other color themes as well:

I’ll think about it. :thinking:

[EDIT] I can’t do anything about it as long I use that “lighter red” as “alt” color. It seems Ardour is doing some calculation and invert, or select another, foreground color for the alert text while blinking. :roll_eyes:

In the meanwhile you can disable blinking in Preferences > Appearance > Graphical User Interface > Blink Alert indicators ( The Ardour Manual ).

1 Like

That did it. Thanks!

O, cool stuff! A distinct&pleasant color decisions//

As a “G / E difference big idolater” I’d like to add some corrections to:
Preferences>Appearance>Colors>Transparency
editable region - to the left;
midi frame base - to the right
G_E_difference

…but everything is subjective :)) Thanks&good luck!

1 Like