Open Session dialogue wait on Linux OS distros

Hello, guys! It’s my first topic here and I’m sorry if I happen to not express myself properly at any time (rusty english).
Well, something’s bothering me with ardour on some distros.
That’s what happens: When I click to launch Ardour it takes a time until dialog window from session manager appears. Now I’m using Fedora 30 under KDE and this happens on fedora (since previous versions) and on Ubuntu above 18.04, however, ardour can launch instantly on KDE neon (which uses ubuntu 18.04 base) and on Kubuntu 18.04, but this wait is happening on 19.04 and Debian 10, for example. Can’t remember for sure if Manjaro got it too…
Anyway, I really like Fedora even KDE Neon being so amazing and stable, but this is a pain in the ass! If my session crashes it will take a long time to relaunch.

Does anyone know why this occurs?
I don’t want to change my distro again just because of this.
Cause Ardour works pretty well on Fedora, but I don’t know where to begin to try solve this at once.

How can I help beyond this:


PS: Session loads pretty normal, no problems at all.

In short: Your distro uses a new fontconfig format that current Ardour5.12 binary does not understand.
On most distros that issue is not critical though. Ardour should come up just fine, and fonts look OKish.

This will be fixed with upcoming Ardour6 (actually it’s already fixed for nightly pre-alpha builds).

Hey, Robin!

Thanks for your reply.
This explains a lot … So, If I wish getting over it I should stay on 18.04 or older versions of Fedora for now?
There is no way to mitigate this “problem”?

By the way: Ardour 5.12 from script shell not from repos.

That is likely the gist of it I suspect, as replacing fontconfig itself with an older version would likely break other things.


Update: I tried ardour from fedora repos and… solved.
But instead opt directory Ardour is installed on usr… idk if means something, but… now I can launch instantly after double click the desktop icon.

Well it means a couple of things.

Distro managed packages are usually installed in /usr. That is normal, the packages installed from here are installed in /opt specifically so they don’t mess with distro installed packaging, and vice versa. It keeps your system cleaner and less likely to break.

The other thing it means is that it was compiled by Fedora, which may or may not have been done correctly. I would have to look at the packaging process to know, but to give an example, Ardour’s packaging process uses specific versions of libraries to avoid problems and conflicts that can come with newer versions of them, etc. and some of those packages are specifically patched to fix issues. Distros tend to want to use system wide packages that may not be patched or may have other issues with Ardour. What you have already seen suggests that a newer version of fontconfig is used for instance, and while it may work fine, you may find some subtle issues later as well that would not be able to be reproduced by the developers of Ardour to fix issues as it won’t happen in the site packaged version they use.

So tl;dr, it may work fine, it may not, but if it doesn’t it will be far more difficult to get help with it, and support is not guaranteed as a result.

I know this comes a little late, but a few people have reported that if you rename the libfontconfig ardour comes with, it will use the external libfontconfig instead and the problem goes away…
(namely for the .run bundle which users can get directly from the ardour site)

the libfontconfig workaround for some of us goes something like this,

cd /opt/Ardour-5.12.0/lib

A couple of other people were mentioning this as a workaround but it is specifically a workaround for the .run bundle. Ardour6 alpha is still some time away and it no longer would have this issue. :slight_smile: