"One or more of the selected filescannot be used by Ardour"

Hi there,

I’ve installed the 2.5 .deb on Kubuntu Hardy (Remix). Install went fine. Creating a new session is fine. No errors in the console. When I try and bring an audio file in (eg mp3/ogg) with import the file browser shows no files at all. Further examination with sndfile-info reveals:

Error : Not able to open input file Outlaws49.ogg. File : Outlaws49.ogg Length : 46436411 Parse error : File contains data in an unknown format.

Supported file format but file is malformed.

I get exactly the same thing with mp3’s from every track I tried (around 25 tracks from 6 different sources). I’m only selecting files without spaces or special characters eg:

  • - Outlaws49.ogg
  • - SXSW08.INT.20080310.StartUpMetrics.mp3
  • - dave001_advanced_testing.mp3
  • I have libsndfile1 (1.0.17-4) installed from Kubuntu repos. I also had the same error with Ardour (2.3?) installed straight from the Hardy repo’s.

    Any ideas anyone? Thanks!

Ardour cannot currently use Ogg or MP3 files. Ogg Vorbis support will likely show up in the next release. MP3 support is further off because of the patent/licensing issue surrounding that format. Note that on OS X, MP3 files are supported because Apple provides a system library to read them (they paid the license fees).

Although I am aware that many people, especially a “younger crowd” used to psycho-acoustically compressed audio, can see no reason for a DAW not to handle such data, it really is outside of the realm of what you should be doing (unless you are just using ardour as a glorified sample playback engine). DAW’s are generally for producing music/sound that will be passed on to others. If your source material is psycho-acoustically compressed, the quality of the final product is compromised, and worse, end users (“listeners”) might compress it again with even more destructive results.

Thanks for the reply Paul (and spoken like a true sound tech, lol! :wink:

Seriously though I can understand and agree with your points on mp3. At this stage I was just trying to open any sound file on Ardour to give it a test run. When I read that mp3 and ogg weren’t supported I thought I’d found the answer. Strange thing is that I’m getting the exact same thing on my FLAC files. The sndfile homepage says it supports flac at the bit depth I’m using and a quick sndfile-info looks happy enough:

Version : libsndfile-1.0.17

File : Realization16bitFLAC.flac
Length : 27800878

Sample Rate : 44100
Frames : 8580096
Channels : 2
Format : 0x00170002
Sections : 1
Seekable : TRUE
Duration : 00:03:14.560
Signal Max : 32768 (0.00 dB)

It does seem to work with 16bit wav files, but only PCM encoded with a .wav extension. Wav files encoded with flac still don’t seem to work either with a .wav or .flac extension, despite sndfile-info looking good (above).

Does this sound worth filing an issue on, or is there a more obvious answer?



FLAC is also not supported (at this time). All audio file I/O is handled by libsndfile, so Ardour can handle whatever it can handle. Note that we use a version of libsndfile that is incompatible with current the current FLAC API - when the next version of libsndfile is released, Ogg/Vorbis and FLAC support will follow naturally. I expect this to happen before the next release of Ardour.

OK, good to know. It kind of threw me when sndfile-info looked OK on the flac but it still wouldn’t open.

Anyway, thanks for your help. From what I’ve seen so far Ardour looks like a nice app with an excellent interface that’s unusually clear for a pro tool, and unusually nice looking for a GTK app. Hopefully this will make a nice addition to our studio’s blender / cinelerra setup. When flac is supported it will be awesome.

A simple little addition that would no doubt help a lot of beginners would be adding something to the “Ardour could not start JACK” popup like: “This is most commonly caused by other open applications that are still using the sound system (eg Firefox, Audacity, Amarok).”

Rock on 2.6! =)