Not sure if export selected regions is working

Select multiple regions in same track -> right-click -> selected regions -> export.

Is this supposed to export all of the selected regions together as one file of the selected format? Because that’s not what happens when I do this.

Version 3.5.146

What actually happens when I do this is the last region in the contiguous group I right-clicked on gets exported (imagine groups of regions that are contiguous and all of them are selected).

OMFG. This… whatever this is really forked up. After this happened, one of this session’s remixes got copied in place of the main session. I DID NOT do anything either in Ardour or in my filesystem to do this. This happened IMMEDIATELY after attempting to perform the export multiple region action I described above. The next time I tried to open the main session, it was a copy of one of the “saved as” remixes. Again, I DID NOT do another “save as” or anything else.

This gave me a HELL of a scare. Fortunately, I the session .backup file contained the actual session. I expect to have to make backups to preserve my data - not to protect sessions from the software I’m using. I have to say that I’m feeling very wary right now. I love Linux, and I love Ardour, but THIS. CANNOT. HAPPEN. Sorry, but it cannot, not even on beta or even alpha software (and yes, I do know what I’m saying from experience in my former career). I would absolutely hate to go back to Windows, but at least there, this kind of thing simply does not happen (well, it never has, to me).

Submitted bug report, hope it actually does something to help:

I have no idea how yhis could possibly happen without user action. Snapshots are accessed internally by the same code that loads sessions - the operation to switch to one consists of “close session, then load session”. There is no shortcut or trivial accident that could make it happen.

Well, I’d like to see concern that it happened rather than the usual “programmer says it can’t possible happen” stuff.

It happened again, and NO user action was involved. I realized I should probably stick with the latest official release, which is 3.5.143, so I downgraded to that today. Yesterday, the last session I worked on was one of my remixes, and after downgrading to the latest official release, I opened the main session and it was a copy of the remix session again. Having gotten wise to this, I’d manually made a backup copy of the main session and restored it.

So, like it or not - SOMETHING is going wrong.


Really need an “edit post” feature here.

Given that I am am the programmer and that I don’t see any way it could happen and that there are a couple of thousand open bug reports and dozens of crashing bugs and dozens of bugs that I cannot replicate, I was merely stating the obvious. Ardour is developed by approximately 1.5 people. There is a limit to what I can be working on at any given point in time.