Not loading U-HE Linux VST


I tried several times to get LinuxVST to run with Ardour. Without Success. Other Ardour-Users have no problem with it. I already contacted the u-he dev-team in KVR forums.
I built the very latest version 3.5.r4033.gf4e0fec-1 minutes ago.

Here is what I tried
screen capture:
Terminal Output: Output:

Maybe anyone can help me to get these plugins into ardour?
Any more infos needed?

I find that with Ardour 3.5.403 in kxstudio 14.04 that all the u-he stuff (version 3284) works perfectly except Zebra and Uhbik which do not work. Zebra and Uhbik plugins can be inserted in tracks but do not generate jack connections or native GUIs and thus are useless. For the other plugins Ardour log window warns:
VST >= 2.4 - this plugin may or may not function correctly with this version of Ardour.
but I do not notice any problems. I know these plugins require glibc 2.15 which prevents them working on some distros.

Ardour nightlies do not seem to be compiled for VST support so they do not run u-he plugins. Anyway, its great to see these high quality synths being ported to Linux.

Unfortunately their dev writes comments like this: “If all your project is managed by Bitwig, then you don’t need jack. I don’t use jack myself. You should can use ALSA directly.” … I don’t even think he has Ardour installed. :frowning:

Unfortunately true.
I tried in Bitwig and Tracktion. In Tracktion is everything fine with the plugins, in Bitwig-Demo it isn’t possible to use “external” Plugins, so no test is possible.
But I don’t think this issue is jack-related.

We talk to abique, the person porting U-HE plugins to Linux regularly on IRC.

The problem is that their plugins come with an explicit dependency on a specific version of glibc, a different version than is installed on your system. We are encouraging and helping him to find solutions to this issue.


Ardour nightlies had Linux VST Support from day zero. The build logs including configuration report can be found directly on the nightly site.
You can check Help > About > Config to confirm in the installed version, too.

However, since Ardour 3.5.1000 or so, ardour does no longer scan for VST by default at first start. Either click “Rescan” in the Plugin Manager
or in Edit > Preferences > Plugins (where one can now also configure paths to VSTs).

VST support has almost complete been re-written since 3.5.403 and all u-he plugin do work.


You need to fix the permission problems listed in your on your system.

See also Ardour does not [yet?] scan recursively.

Meanwhile, you can simply install the u-he plugins all in the same folder e.g. with sudo ./ --vstdir=/usr/local/lib/lxvst/.
Alternatively add all the folders (one for every u-he bundle) to the Linux VST Path in the preference dialog.

I hope that help,


Hm, if you’d seen my video: there I confimed my vst-paths.
Interesting, the last scan didn’t give any .err, further it did not show up in ardour. :frowning:

x42: Thanks for the info about scanning for VSTs, that did the trick. I now find that all the u-he plugins work! (kxstudio 14.04). However, I found that ~/.vst was not scanned so I had to move the symlinks to plugins to /usr/lib/vst. My VST_PATH does include ~/.vst but perhaps Ardour does not use this.

Ardour uses LXVST_PATH (for linux VST .so) and VST_PATH (for windows VST .dll).

Ardour-3.5.403’s default LXVST_PATH is /usr/local/lib64/lxvst:/usr/local/lib/lxvst:/usr/lib64/lxvst:/usr/lib/lxvst
As far as I know, kxstudio plays some tricks with the standard environment. kxstudio uses $LIBDIR/vst also for linux vsts, most other distros use $LIBDIR/lxvst/

With Ardour 3.5.403 those environment variable are the only way to set search paths. All later versions only use these environment variables as initial default for the configuration in the new Preferences > Plugin > Path Settings