Not able to add more than 9 tracks

With the most recent updates in Fedora 19 and Ardour 3.5 I am no longer able to open my old session whcih have more than 9 tracks and or busses. Also if I create a new session I can add only up to 9 mono tracks, or any combination of mono/stereo tracks with up to 9 inputs. I have an emu 1212 card and I was able to record up to all 12 channels from it (using external adat ada8000).

I am getting this error once the limit is reached:

[ERROR]: unable to create port: failed constructor
[ERROR]: could not create 1 new audio track

Same error when trying to add a buss or stereo or mono track. Also same error when trying to open an older session.

I am able to record with Reaper under wine on the same computer.

Any ideas what could be wrong?


Most of the time if you can’t add more tracks, you should take a look at the configuration of jack. Probably it’s limited in the configuration.

cajmere it seems that you pointed to the right thing … although I don’t see any limits in jackd that would cause this. This is the command line which starts jackd (max number of ports is set to 128):

/usr/bin/jackd -P89 -p128 -t2000 -dalsa -r44100 -p512 -n2 -Xseq -D -Chw:EMU1010,2 -Phw:EMU1010,0 -i16 -o2 -zr

When I run reaper in wine, it also uses jackd and I can see that 12 inputs are connected to reaper.

Now I tried setting max number of ports to 256 and ardour seems to be able to create more than 9 inputs.

I seem to be ok now, still don’t understand why would max number of ports set to 128 limit ardour to only 9 inputs?


There are more ports than you would think involved in setting up Ardour IIRC. For instance Click/Audition/etc. I can’t tell you if that number seems high or low based off your experience, except to say 128 is a really low number for most people to use;)


128 is really low, i have mine set at 2048 (default settings)