Noise problem recording electroacoustic guitar in Ardour (line in).

Hello everybody…

I want to record my guitar in ardour, using the “line in”, but when i record something and play it there is a noise like an old radio tuner.
I’ve recorded using the “sound recording” tool provided with ubuntu and there’s no problem. The sound is so clear.

So i think is a configuration problem with Ardour, but I don’t know how to solve it.

Can anyone help me?

I’m using my integrated sound card:
with “lspci” i get:

-Audio device: ATI Technologies Inc SBx00 Azalia

Thnak you very much

Hey!

Man, I think it’s a bit tough to know exactly what you’re suffering from, but I’ll try…

When you are about to record (when the red recording button is blinking), without playing any notes, what kind of signal do you get on your track? Is it low on the blue, or is it showing a significant amount of signal? If the track is showing that kind of noise, then I think you need to understand where it’s coming from. If you are adding a compressor on the pre-fader stage, adding too much make up gain could cause quite a lot of noise. Likewise, any preamp could add noise if you go too far with amplification.

Another thing I would check is your configuration on the mic from your sound card. I think there are some controls which allow for boosting the mic signal, and you might want to turn those down.

Having said all that, it’s strange you are getting a clear signal from other applications…

My two cents, good luck!

Is it a sweeping radio tuner noise? It could be a comb-filtering artifact caused by the signal being mixed with a delayed version of itself.

i would rather think it’s a sample rate issue … what is your jack setting ? 44.1 kHz ? if so, try 48kHz.

Thanks everybody.

“GodLikeCreature”:
I’m not using any preamp, im recording directly from the line int with an electroacoustic guitar, so i don’t know how to fix mi problem.

“thorgal”:
I have tried with 48Khz sample rate but no luck.

Now i moved to ubuntu studio but the problem still here, and now i can’t record from “sound recording” app, that noise again!

I think the problem is with my sound card configuration, but i’m not sure.

In MS windows i use adobe audition and i can record very well, no problem, so the problem isn’t in my sound card, i think…

This is a sample of what i’m tryin to fix:

http://www.badongo.com/file/13327272

Any suggestion?

Ground 101–sorta:

This could be ground 101 if I really knew the material, I don’t.

Imagine a bicycle wheel with no outer rim. Each spoke is an audio wire that returns and grounds at the hub. The hub is a mixing console.

The mixing console has one power source and consequently a single ground–no chance for ground loops. Unless another power source and ground are introduced into the star.

If a spoke has a powered instrument at the opposite end from the hub and that power doesn’t use the same ground as the mixer, it’s probably gonna loop–noise. Many buildings have more than one ground; earth ground, ground to plumbing. Ground to plumping often breaks at the water meter because the meter is a physical break. Be sure to wire the copper on both sides of the meter. Test by producing the noise, have someone hold wire across both sides…

Guitars, especially single humbucker, are noisey instruments.

Another source of noise is radio frequency. Analog audio circuits within the case of a computer need to be shielded.

I won’t pretend to be an expert but experience has helped me prevent and eliminate noise. As circuits are concerned, you need to understand what a grounded circuit is and then imagine ways of isolating all gear onto the circuit. If you know several circuits have a common ground then there won’t be the chance for loops and you can use all those circuits.

Don’t lift ground on your power it’s dangerous. Ever play guitar, sing, touch mouth on microphone and get a shock? I’ll bet ground was lifted on your guitar amp.

We all lift ground on laptop computers because the circuits in those power supplies are junk. And we lift it by default so we won’t have to back track. Newer laptop design solves the problem by not having ground–WTF is up with that?

If your using an older laptop lift its ground, that will prove to be your problem.

José,

You are using the infamous intel HDA. Set your number of periods per buffer to 3 in the jack setup. See how it goes.

Hi again,

Very stupid check but… Is your guitar low on battery? I always find myself concerned when working with piezo pickups or any instrument amplification method which uses a battery… I recommend you use a brand new battery, just to be sure it is out of the equation of potential problems.

On a different note, some other things I didn’t mention:

  • A tube monitor always is a source of noise.
  • Bad AC power or sockets could also cause noise.

In any case, those issues would also affect any other recording method/application you could be using, so not sure this will help…

Hi again.

I’ve changed my battery but no luck…
It’s weird, in windows with audition i have no problem… but i like Ardour…

I don’t know what to do…

Have you tried another jack recording app ? you said the default sound recorder in ubuntu was doing fine. I presume it was using the ALSA or pulseaudio layer. Can you also post your jack setting ?

Hi!

“thorgal”:

Yes, in Ubuntu the default sound recorder was doing fine but ardour wasn’t.
Now i’m in Ubuntu studio, here the default sound recorder seems not to work… same problem like ardour.

This is mi jack conf:


have you checked the level setting for the line in in alsa mixer?
could be that it’s set too low.

José, you have not ticked the RT mode option. How come ?
I doubt it comes from there though.
Could you post the output of :

lsmod | grep snd

cat /proc/interrupts

uname -a

It sounds a little bit like xruns but that’s not what it is, because the noise level seems to be somewhat proportional to the signal level. In the pause before you begin playing there is silence, and as the last chord decays, so does the noise.

Try setting “Interface” in the Qjackctl settings to the specific hardware device you’re using. On my system I have on-board audio hardware, a PCI audio card, and sometimes a USB web cam (with a built-in microphone). There have been times when the numerical ordering of these three devices has been changed, and I’ll know immediately because I start having problems with JACK.

Hello everybody!!!

“thorgal”: I have checked the RT option in Jackcontrol with same result, noise when i record my guitar.

“duffrecords”: I also play with the “interface” options, setting one by one but no luck…

This is my outpouts for:

lsmod | grep snd

snd_rtctimer 4640 1
snd_hda_intel 346136 3
snd_pcm_oss 42400 0
snd_mixer_oss 18048 1 snd_pcm_oss
snd_pcm 78852 2 snd_hda_intel,snd_pcm_oss
snd_page_alloc 11400 2 snd_hda_intel,snd_pcm
snd_hwdep 10628 1 snd_hda_intel
snd_seq_dummy 4868 0
snd_seq_oss 35968 0
snd_seq_midi 9376 0
snd_rawmidi 25632 1 snd_seq_midi
snd_seq_midi_event 8576 2 snd_seq_oss,snd_seq_midi
snd_seq 54992 7 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 24836 3 snd_rtctimer,snd_pcm,snd_seq
snd_seq_device 9612 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 57636 19 snd_rtctimer,snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_hwdep,snd_seq_dummy,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore 9312 1 snd

cat /proc/interrupts

       CPU0       CPU1       

0: 481 6 IO-APIC-edge timer
1: 2 1501 IO-APIC-edge i8042
4: 0 2 IO-APIC-edge
7: 0 0 IO-APIC-edge parport0
8: 1 7 IO-APIC-edge rtc
9: 0 1 IO-APIC-fasteoi acpi
12: 75 52323 IO-APIC-edge i8042
14: 38 38846 IO-APIC-edge ide0
16: 0 2909 IO-APIC-fasteoi ohci_hcd:usb3, ohci_hcd:usb4, ohci_hcd:usb7, nvidia
17: 4 9568 IO-APIC-fasteoi ohci_hcd:usb1, ohci_hcd:usb2, HDA Intel
18: 0 3 IO-APIC-fasteoi ohci1394
19: 0 0 IO-APIC-fasteoi ehci_hcd:usb5
20: 0 0 IO-APIC-fasteoi ehci_hcd:usb6
220: 5 5902 PCI-MSI-edge eth0
221: 0 0 PCI-MSI-edge ahci
NMI: 0 0 Non-maskable interrupts
LOC: 1606479 1608252 Local timer interrupts
RES: 76088 13651 Rescheduling interrupts
CAL: 4434 5541 function call interrupts
TLB: 1522 1479 TLB shootdowns
TRM: 0 0 Thermal event interrupts
SPU: 0 0 Spurious interrupts
ERR: 0
MIS: 0

uname -r

Linux Undertaker 2.6.24-23-rt #1 SMP PREEMPT RT Mon Jan 26 02:29:24 UTC 2009 i686 GNU/Linux

Thank you…

what is your input level?