Noise on master channel

I’ve just recently upgraded to DeMuDi 1.3, which has Ardour 0.99.3 (I think).

When using the mouse to click somewhere on the timeline to re-position the playhead and when using the spacebar to start and stop playback there are loud clicks that are rather annoying.

Also, after the clicks have started occurring, when transport is stopped the master channel levels flicker away as if playing back. The levels start off fairly low but gradually get higher. On occasions they’ve suddenly gone haywire, shooting up to something like +300 dB! Fortunately, I route my soundcards output through the monitoring stage of a Focusrite TwinTrak and the mute button is close at hand!

Is there anything that can be done about this?



It’s probably a ladspa EQ plugin. Solo each track with any plugins and see which ones light up the master meter when the transport isn’t rolling.

We’re really hurting for a good ladspa EQ.

-Ben Loftis

Thanks for that, I’ll have a look. I have had problems in the past with some plugins, usually EQ, going haywire until you remove them and start over.

Although as I’m re-recording a couple of parts in a previously-finished project I’m reluctant to have to go removing too many plugins and having to re-mix the whole thing from scratch again. Plus there are about 20 tracks, all with EQ, to wade through…

I’ve also just noticed that something screwy is going on with crossfades: occasionally they’ll play properly, but most of the time there are horrible screeches, clicks, weird dropouts or volume changes and even “bleed” from other tracks that are muted. Save the session, close Ardour, start it up again and it’ll work fine, or be odd in a completely different way.

There definitely seems to be something weird going on.


I can see we are pilgrims and so must walk this road
Unknown in our purpose, alone but not worthless
And home ever calling us on…

Yep, it was one of the EQ plugins – the one on the track that I was working on and the first one I looked at, which saved a lot of time. I cut & pasted it to another track and the master level dropped down immediately. I inserted a new EQ plug, opened them both up, set the new one with the values of the old one, then cut the old one completely.

Not only is the master level now normal when the transport is stopped, but I’m not getting any bizarre behaviour with the cross-fades that I’m editing.

It must just be a coincidence that this EQ plugin started acting up at the same time that I started using the newer version of Ardour. Such is life!


I can see we are pilgrims and so must walk this road
Unknown in our purpose, alone but not worthless
And home ever calling us on…

I’ve found Steve Harris’ “Triple band parametric with shelves” to be bug free and great sounding, but that’s just my opinion. How do you like it?

I agree that the LADSPA world needs more plugins. Especially more plugins with sense of character. Current plugins are quite bland textbook -style implementations. They do get the job done, at least for me.

Sorry I’ve not been round in a while to follow this up.

The EQ plug that was causing me problems is the “triple band parametric with shelves”, which is a shame as I find it to be really useful.


The triple band seems to suffer from denormal issues. It seems that compiling the plugins using SSE instructions will make thte denormal issues vanish (and make the plugins even faster in the process).

I tried replacing a few instances of the TBPwS with the GLame High Pass filter in the few cases where all I was using the TBPwS for was high pass filtering. However, as you’ll see from the other topic I started, the GLame HP is causing massive problems with Xruns due to denormals.

This compiling using SSE instructions thing sounds good, how do I do it? Sorry, I’m a bit clueless about compiling things – I’ve just been using the plugins as they came with DeMuDi.



No problem. It’s not that difficult.

First of all, I recommend you install the plugins “on top” of the distro package. This way the distro knows that the plugins exist (even though they aren’t the plugins it installed).

Get the source package for the newest swh-plugins.
Untar it (tar xf [package]).
Go to the directory created.
Run configure like so: ./configure --prefix=/usr --enable-sse
(the --prefix=/usr makes it install itself to the same place as the demudi packaged plugins)
The run make
After that’s finished, run “make install” either as root, or as sudo.

That’s it. :slight_smile:

Thanks for your help, but nothing ever goes smoothly for me :-). The configure step returned the following error:

*** The pkg-config script could not be found. Make sure it is
*** in your path, or set the PKG_CONFIG environment variable
*** to the full path to pkg-config.
*** Or see to get pkg-config.
checking for fftw_one in -lsfftw… no
checking for fftw_one in -lfftw… no
configure: error: Could not find working FFTW library ( If you have
installed FFTW3 check that you used the right build options, see the README.

All of which goes completely over my head! I looked in Synaptic and I have fftw2 and fftw3 installed. Can you guide me through this?

Many thanks


Okay, so I’ve now installed pkg-config, but that still leaves me with this FFTW problem.


most linux distributions separate library packages (like FFTW) into the parts needed by people who just wish to run software that uses the library, and the parts needed by people who want to compile software that uses the library. you probably only have the first version installed; the second version is generally the name but with a “-devel” attached (e.g. fftw-devel, or fftw3-devel, etc).

please note that we really do not intend for people without significant linux software development experience to compile ardour or related tools.

I did wonder whether I needed the dev package as well.

Well, I’ve now compiled the SWH plugins as suggested and I’m still having problems with denormals – even when I’ve removed plugins and inserted them afresh (but it’s the plate reverb that’s the cause now, rather than the triple band parametric).

This is all getting very frustrating, although I realise it’s the plugins that are the problem not Ardour.

I found the solution to your (and mine too) problem.
Steve Harris’ “Triple band parametric with shelves” generates low frequency noise when the frequency of a filter is set to or near to 0Hz, even if the gain is 0db.

Just set the frequency of ALL filters to something far from zero. And the low frequency noise is gone.

Hope this helps other people. It took 2 days to figure this out.