Noise on export

First of all sorry if my question is some sort of noobish, but you see I just started working with audio processing software and am at the beginning of digging myself through. So if I sound noobish it’s because I most probably am.

Enough for the disclaimer - I am running ardour 2.8.2 on UbuntuStudio Karmic. I managed to record stuff from various locations, some directly with ardour and some I imported from another application. No problems so far, I got everything set up so that when I listen to my creation in ardour everything sounds as I intended it to.

Now when I try to export the track I get sharp high-pitched noises in any file ardour creates (listening to the file via VLC while Jack is terminated). The song plays, but there are additional scratch-on-glass-like noises that hurt in my ears and that are not present when I listen to my creation in ardour.

I used different variations for export, but no luck. I’d like to export to CD quality (16bit, 44,1 kHz).

Now I get the feeling I did something terribly noobish and easy to circumvent. But I was unable to find anything related in the forum so I’d appreciate if someone could just point me to it.

Thank you already in advance

  • Halogene -

What is your samplerate for jack?

Can you re-import the file into ardour and verify its distorted?

Do you just export a track, without additional (external) programs in the signal path?

(I have problems with jconv in freewheeling mode, workaround is to first write to a bounce track and then export that track.)

Just some ideas…

  • Andreas -

The samplerate in Jack is set to 44100. I can re-import the file into Ardour and it is NOT distorted when I play it back from within Ardour. I tried to re-export the file, but the output again sounds horrible. This is obviously not connected to VLC, as Audacious produces the very same noise.

There should not be any additional programs in the export path, as I wouldn’t (yet) know how to do that. But speaking of the sample rate Ardour mumbles something like “there is missing data for the audio setup value of sample rate” on startup (this is a translation, so the original English wording might be different). But up to now I didn’t find a place where to provide Ardour with any such data.

Also, there is a warning that Ardour found my system limits the reservation of memory and suggests to change the settings in /etc/security/limits.conf. But I did not find anything that looked like limiting the reservation of memory there… I might take a look into some forums regarding this.

What I do is start Jack Control, from there start the Jack Server, and then I start up Ardour. Nothing else running. Jack connects Ardour in- and output to the system’s in- and output. Ardour’s in- and output seem to be connected too.

Anyway, thanks for replying, any ideas are welcome.

@halogene: play the file with sndfile-play (sndfile-jackplay for extra convenience) and/or check it with sndfile-info.


what soundcard are you using?
some soundblaster maybe? i don’t have one but there are plenty of posts, that address problems with soundblaster and linux/jack. they usually talk about glassy distorted sound… the solution is to set the samplerate to 48000 in jack. i guess you can still export with 44.1 in ardour then, but i’m not sure about this. (otherwise you can do the conversion after exporting)

hello Paul,

playing the file with sndfile-play did produce the same distorted sound as vlc or audacious produced. The check with sndfile-info did not produce anything of interest as far as I can tell. It is encoded in 16bit, 44,1 kHz, 2 channels, block align 4, bytes/sec 176400.

I tried to raise the memlock for the audio group via the etc/security/limits.conf, but still get “64” as sole output of “ulimit -l”. But I am not sure this is related anyway.

  • Halogene -

I am using some onboard sound chip, would have to look what it was again. I do have an old audigy card lying around somewhere, but it is definetely not build into my rig.

I tried using 48 kHz for exporting from Ardour, but I will try to set Jack to 48 kHz just for testing. Thanks a lot for the tip, I’ll post the result.

  • Halogene -

Edit: nope, same result :o/

@halogene: please post the output of sndfile-info when run on this file.


Version : libsndfile-1.0.20

File : project/export/export.wav
Length : 51260512
RIFF : 51260504
fmt : 16
Format : 0x1 => WAVE_FORMAT_PCM
Channels : 2
Sample Rate : 44100
Block Align : 4
Bit Width : 16
Bytes/sec : 176400
data : 51260468

Sample Rate : 44100
Frames : 12815117
Channels : 2
Format : 0x00010002
Sections : 1
Seekable : TRUE
Duration : 00:04:50.592
Signal Max : 17307 (-5.54 dB)

That is the full output of sndfile-info. This file was exported with ardour and jack set to 44.1 kHz sampling rate. If you find anything of interest, I’d be happy to know.

  • Halogene -

@Paul: Never mind, I solved the problem. For anyone who might be interested it was not related to Ardour at all - I had set my sound configuration in the System’s audio settings to 5.1 analog output. Now when I changed the settings to stereo output the noise disappeared. Apparently Jack overrides the 5.1 setting or I don’t know but anyway the sound of the file is clean and as I hear it from within Ardour now.

Would be interesting to know why I get such distortion on a 5.1 setup, but that’s not for this forum :o)

Nevertheless a big thanks to all your time.

  • Halogene -