Hi guys. I am using Ardour 6.9 on Linux mainly, but since I have a dual boot system, I also have Ardour 6.9 on Windows 10. The main intention in doing this is to be able to use VST virtual instruments in Windows, importing MIDI regions from my main session and recording them to audio tracks using those VSTs. After that, what I have to do is just export those audio files and use them within my main session on Linux. In this way, I can use some virtual piano, for example, which is not available for Linux.
Well, the problem comes with certain VSTs, not all. In particular, Ardour easily recognizes Sforzando and IK SampleTank in VST3 format. But I have tried to get two others to work and it has become impossible. These are Keyzone Classic and MSound Factory by MeldaProduction, the latter for the Monastery Grand piano VST, as it is the only valid sample player for this virtual instrument.
Are there any known issues with VSTs not working within Ardor in Windows environments?

The only general limit is that 64bit Ardour only loads 64bit VSTs.

If you have some older 32bit plugins, then Ardour cannot use them (well, you could install 32bit Ardour, and have the opposite issue).

As for specifics have a look at Ardour-Menu > Window > Plugin Manager

For VST2 plugins you may have to set a search path, since there is no standard location for VST2 plugins on Windows. This can be done in the Plugin Manager (button bottom right) or Preferences > Plugins > VST.

Thanks, Robin. Maybe these ones are VST2 plugins and the problem is with the plugin path. I´ll try and have a look at that later.

No lucky so far. Ardour does scan the plugins, but with status: error.

And they actually are 64 bit VSTs

Does the Log (at the bottom) have any useful information when you select them?

But given that the VST3 also doesn’t work, there’s likely some other incompatibility with the plugin and Ardour.

Great! Keyzone working as VST2. Sounds terrific with the Yamaha and Steinway samples. I think I’m gonna stick with this.
Thank you, amigo

Mistery solved. I’ve just tried with Cubase and the program listed the Melda plugins as not-compatible. So it’s not a problem with Ardour, the error is with the plugins themself. The same thing happens with two differents DAW. It’s a pity because the Monastery Grand samples sound fantastic in the demos.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.