No startup with fedora36 since 2 days

Hello Ardour and linux lovers,
I was working still fine with ardour 7.2 two days ago and, is it because I did some refresh with the latest code of Fedora 36, when I start Ardour it just shows me some standard logo from fedora and no window. I downloaded Ardour 7.3 just now. But no improvement; Unless you have a suggestion, I will go to Fedora’s latest version…

No problems here with Fedora 37 and Ardour 7.3…

What is “some standard logo from fedora”?

What happens when you run it from the command line? /opt/Ardour-7.2.0/bin/ardour7 or something like that.

Ok I tried with terminal, here is the message i got :

k-Message: 22:56:52.061: Failed to load module "canberra-gtk-module"
Gtk-Message: 22:56:52.061: Failed to load module "pk-gtk-module"

it’s a blue square with a drawing of sprockets inside basically…!

I remember there are some troubles with gtk, and I have Ardour working with this little script that I named “” and start from the commandline (but you may start it from some GUI), and please insert your correct path to the Ardour binary:


Succes, Frans

1 Like

Thx works fine now !

1 Like

I’d like to note that if you were using the ardour build from, this would not happen. Just another minor irritation with distro builds …


Hello Paul,
With all due respect, unless, I did some unconscious use of a distro builds, I always download from Otherwise, why would I give a small amount of money monthly to Ardour ? :wink:
Might be also Fedora, I can’t figure out what is going on…

What path did you have to use with that “unset GTK2_RC_FILES” setting?

Sorry, I got it right but not using that hint. I could not get round this path… I set up Fedora 37 and fortunately it worked out… Thought I have still the same pb than another person with No input for audio channels (No input for audio channels Ardour 7.3.0).

Are these Fedora systems defaulting to Pipewire?

yes Fedora has implemented Pipewire since last year. Had no pb with that up to now.

I sometimes use also “Reaper” and I have the same pb…

In general I think you can better use ALSA than Pipewire. As I understand: with Pipewire you share your devices with different programs/services (e.g. so both your browser and musicplayer can stream audio to your headphones), while with ALSA you get full access to your device: this gives far better results on my system (no more sampling errors or x-overruns, lower latency). Maybe this thread explains it better: How does PipeWire perform with Ardour? - #12 by x42
(with information from Robin Gareus)

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.