No input for audio channels Ardour 7.3.0


I am using Fedora 38 on a AMD R7 with 32GB RAM and installed Ardour using Fedora repos.

I am using pipewire which works fine with Bandlab (browser based) and Audacity.

For Ardour7 I don’t have audio input so I can’t record audio channels, I us QJackCTL to see the audio flows and Ardour has no audio inputs. I am mainly using PulseAudio in the audio configuiration window but I tried ALSA and Jack, same issue, no input so no way to record audio channels,

Please, need help

What audio interface?
Use the ALSA backend until you get the problem understood, that has the fewest complications.

All of them, PulseAudio, Jack and ALSA, same issue, thanks

I meant are you using the audio interface built into a motherboard, a USB interface (which brand and model?), a PCIe interface in a desktop computer, etc.

Oh, I am using the laptop’s mic, not even tried an USB audio interface yet… Mic and integrated audio works fine, btw:

03:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h/19h HD Audio Controller

Hardware works fine using either the embedded mic, headset with mic and USB audio, with Audacity.


While running Ardour, run this command

cd /tmp && wget && bash ./

It will not modify your system.

Paste the output here.


–2023-05-04 20:46:09-- https://xxx/files/adevices.h
Resolving xxx (xxx)…
Connecting to xxx (xxx)||:443… connected.
HTTP request sent, awaiting response… 404 Not Found
2023-05-04 20:46:10 ERROR 404: Not Found.

There was a small typo in Paul’s message, try that line:

cd /tmp && wget && bash ./

Part I: ALSA
Advanced Linux Sound Architecture Driver Version k6.2.14-300.fc38.x86_64.

Card 0 (Generic):

  • Playback Device 3 (HDMI 0):

    • Subdevice 0 (hw:Generic,3,0):
  • Playback Device 7 (HDMI 1):

    • Subdevice 0 (hw:Generic,7,0):

Card 1 (Generic_1):

  • Playback Device 0 (ALC3204 Analog):

    • Subdevice 0 (hw:Generic_1,0,0):
      used by: pipewire (PID 2402)
      access: MMAP_INTERLEAVED
      format: S32_LE
      subformat: STD
      channels: 2
      rate: 48000 (48000/1)
      period_size: 1024
      buffer_size: 32768
  • Recording Device 0 (ALC3204 Analog):

    • Subdevice 0 (hw:Generic_1,0,0):
  • Recording Device 2 (ALC3204 Alt Analog):

    • Subdevice 0 (hw:Generic_1,2,0):

Card 2 (acp):

  • Recording Device 0:
    • Subdevice 0 (hw:acp,0,0):
      used by: pipewire (PID 2402)
      access: MMAP_INTERLEAVED
      format: S32_LE
      subformat: STD
      channels: 2
      rate: 48000 (48000/1)
      period_size: 1024
      buffer_size: 4096

Part II: jack processes
26075 pts/5 S<l 4:02 qjackctl

Forgot to mention in the earlier response that the PulseAudio backend has no recording capability by design. That backend is not relevant if you are using Pipewire and not the original PulseAudio server.

The ALSA backend will request exclusive use of the device and Pipewire will stop using the device. A screenshot of the audio/MIDI setup window showing the parameters you select would be useful in that case.

If you have pipewire-jack installed then the Ardour JACK backend will use the Pipewire JACK server. That appears to be what you are using, or attempting to use, when the script to check the ALSA devices was run.

The output from the script to check alsa devices indicates that you are using different devices for recording and playback. That requires some additional setup with jackd, but according to the pipewire FAQ that is handled relatively transparently.
Presumably the playback device is the motherboard integrated audio, and the recording device is the camera microphone.

The program jack_lsp was traditionally used to list jack ports. It will still work with pipewire, but if you do not have it installed the native pipewire program to list ports is:
pw-link -iol

Run that and check to make sure your microphone is shown as an input.

Can you screenshot the audio connections window of QjackControl and paste it here?

1 Like

Hi! Using Jack audio backend, opened QJackctl and connected the correct capture devices tu audio input:

Now I can record and play audio, thanks a lot!!!

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.