No sounds from any MIDI instruments

After creating a MIDI track and adding an instrument (I’ve tried Calf Monosynth, a-Reasonable Synth, a-Fluid Synth with a soundfont loaded), clicking on the piano roll keys does not produce any sound or meter activity. Drawing MIDI notes in the track, then pressing play doesn’t either. Something is wrong with the internal MIDI routing, and I cannot figure it out.

Everything else is fine in my setup; I can record and playback audio in Ardour, and I can load Calf Monosynth in the Carla host, connect my MIDI keyboard, and make some noise just fine. Somehow I have screwed up something in the MIDI or track configuration in Ardour.

I’ve tried Ardour 5.8-10 on CentOS 7.

Like I said, it “does not produce any sound or meter activity.” But I started a completely new session, and this one works. No idea what happened with the other one. The routing looks correct.

Do the meters on Master show audio? Check that the audio outputs of the MIDI track are routed into Master.

This can be turned off and on in Prefs -> Editor -> MIDI. You choose the auditioning synth there also. The audio goes to auditioner outputs so route those where you can hear them.

Was this solved? Does it have activity in the orange bar? And have you checked the pin outs of your midi instrument?