No sound & problems with connections

Hi everybody,
I need help for the configurations, since I have never been able to play/record anything using Linux.
My system is an AMD Athlon II X4 630 64 bit processor, 4GB RAM DDR3, 700GB Samsung Hard Disk.
The sound card is integrated in the motherboard (which is a MSI 770 C-45).
The video card is an ATI Catalyst: I’m using a Samsung 26" TV as a monitor for my system and it is connected through a HDMI cable with the video card.
I have Linux Mint 11, kernel 2.6.38-8-generic, Gnome 2.32.1, Jack 0.3.7 and of course Ardour 2.8.11.
In my motherboard’s line in I have plugged a jack connected with a Zoom G2 guitar effect which is, of course, connected to my Jackson Soloist SL-2h.
I set jack to work with a latency time of 11.6 msec (period = 256) and it works fine, I get a xrun every 10 minutes.
Every volume meter in the ALSA Mixer is open and quite high.


  1. I cannot hear anything using Ardour: even if I import a little .wav file, I can see the mixer volume meters going up and down, but sill hear nothing.

  2. I cannot listen to myself when I record something, even though I selected the Duplex mode in Jack and in Ardour settings.

  3. I tried to record something using Audacity: it worked, but the volume level was too high even if I put it at 1/100 in the ALSA Mixer… Moreover the signal was very disturbed, even if I had the Zoom Noise Control switched on!

Please help a young and promising guitarrist use Ardour :smiley:

First, I would read this if you have not already:
If you do not hear anything check your Jack connections. Make sure Ardour Master Out is connected to the system out.
To have Ardour do monitoring select Options->Monitoring->Ardour does monitoring

Ok I started Qjackctl and Ardour GTK2.
Jack is green and no xruns.
I set monitoring by Ardour as you told me.
This is my jack:
I imported a wav file 3 minutes long in Ardour.

No sound.

I followed your link, but it just takes me to an orange page with a form to fill to ask questions and …

Since I’m using HDMI out audio, I went back to hw:1 HDA ATI HDMI in the jack settings… but still…
No sound!!!


Look on the left hand side of that page. You will see links to every page of the FLOSS manual for Ardour.

In as far as your setup, it looks like everything is good except you may not be routing to the correct outputs(This depends on your exact card and setup). Connect your Master Outs to the other outputs(playback_3-8) and see if you get audio on any of them.


Just did as you said: I connected every master out to every system output…and still no sound.
Plus jack wasn’t recognising my HDMI connection anymore, I had to switch back to Analog in the interface


If you are specifically wanting to use Linux for recording a guitar or anything else, why not try a Linux intended for that? Linux Mint is an amazing Desktop OS but I don’t think it’s forte is audio recording.


KX Studio:
It’s packages should be compatible with Mint

Dream Studio:
Ubuntu-based with a LiveDVD also compatible with Mint and KXStudio packages

AV Linux:
A complete self contained Linux Audio focused OS ready to use.

One week passed…
Nothing new, you cannot record an electric guitar using Linux, no way.
I’ll have to switch back to windows XP.
I have a 64bit athlon and can’t get it to work…200$ thrown away.

Nothing new, you cannot record an electric guitar using Linux, no way.

This isn’t true. I just did it this morning.

Thanks guys, but I don’t think it’s a problem of Linux distribution.
I mean: Linux Mint is based on Ubuntu and Ubuntu features a lot of good programs (Audacity, Hydrogen, Ardour, Rosegarden, Jack, Timidity, …) and it does not need a real time kernel, since from Ubuntu 10.10 on, the linux’s kernel is no different from the real time one.
What I don’t understand is WHY am I not having sound?
Why isn’t it working?
What am I doing wrong?


You have hit a point where your question is probably best addressed over IRC (Help>Chat in Ardour) where we can help you troubleshoot in real time as opposed to the forums which may take weeks to find the source of a problem. Your problem is likely related to your specific Jack setup, and since you are using consumer hardware, there can be all sorts of hoops that have to be jumped through in order to get this to work(For instance it may only work at 48k). Jack and Ardour were designed to work first and foremost with professional interfaces, so getting them to work with consumer hardware which can cut corners like crazy to save cost(For instance many will only run at 48k) can be tricky.


Dear seablade,
I still cannot get sound in Ardour.
I’m trying everyday in my free time to solve this problem, but still cannot get any help from anyone.
I’m posting my problems on #ardour


I see you made progress on IRC at least, so good for that, yea you can probably guess why I mentioned IRC is a much better venue for your particular problem, it isn’t an easy one to solve and would take months to do what you just did over the forums:)


Hello everybody.
First of all I want to thank you all for having helped me in getting things working.
My problem was that I am using an HDMI cable, which is NOT built for professional audio applications.
I cannot remember the nickname exactly, but thanks for the ones who helped me fixing all my problems in the IRC chat #ardour.
Thanks again!

somehow, ardour DONT start jack automaticly,
try to start JACK first and THEN Ardour.

Had the same problem.

Start Jack
go to parameters
chose youre audiodevice klick on OK and start ardour

appending to a thread that is 6-7 years old is not helpful.