No sound output in Ardour

Hello. I have recently installed Ardour on my Ubuntu system and after an afternoon of trouble have managed to record guitar from a USB input (using the “lightsnake” USB cable)

I am unable to hear any playback (monitor or pre-recorded) through my headphone jack. I have tried every available output option in JACK as well as trying different options for the output in the ardour mixer. I can hear sound otherwise on my system (music, system beeps etc) and I can hear my recordings after exporting them to an external app. I have searched myriad forums and tried the suggestions therein but so far without success. I am probably doing something stupid and am hoping someone can tell me what it is.

Thanks, Andrew

This is a problem with Ubuntu. We are writing up a page on this issue for those people who have unfortunately chosen Ubuntu as a platform for using JACK and Ardour. I will post a link here when the page is done.

OK Thanks.

On that note, is there a prefered distro for Ardour? Switching wouldn’t be out of the question for me.

I’ve used Zorin 6.2 core, Linux Mint - 13,14 with KXStudio, AVLinux-6.0 without any issues.

On the more general topic of distributions who cannot maintain ardour builds, I’ve recently discovered that A2 builds shipping with Ubuntu Studio appear to be broken (incorrectly linked against LV2 libraries meaning that plugin GUIs don’t work again) - as far as I can tell this applies to all plugin UIs - a simple test would have shown this up. Early indications are that Open SUSE is affected in the same way. I’m very strongly considering only offering support for my plugins if used with genuine builds from (or an official recommended distro).

new to ardour 4. I can’t get any sound. I am simply importing .wav file to practice using the software and therefore have no external hardware hooked up. I am on a macbook pro running Yosemite.

We don’t generally attempt to solve generic problems like this on web forums, which are slow and inefficient when repeated back-and-forth is required to figure out what is going on.

Go to the support page (link at the top of this page, near the top right corner), and read (or just click) about getting onto IRC where the chances are good (but not guaranteed) that someone will offer you real time assistance, saving us and you attention time.

Thanks, I did find a solution previously posted that worked. I simply had to set up an aggregate device. I thought it wasn’t necessary since I wasn’t at the time using multiple devices.