No playback with Ardour and StudioLive AR16

Hi everybody,

I’m trying to set up a recording environment for my band with Ubuntu 16.04.3 LTS (kernel version 4.4.0-101-generic), Ardour4 and Jack 1.9.11. As an external soundcard I’m using a Presonus StudioLive AR16. Everything seems to work fine except for the playback. I’ve read a lot of wiki pages and forum posts, but nothing seems to help. The strangest thing is that it worked a couple of days ago and I haven’t changed anything significant (?) since. Here’s what I do:

I start Jack via QjackCtl. Before I start Jack, I choose my StudioLive AR16 as interface in the QjackCtl settings. As server path I use /usr/bin/pasuspender – jackd in order to suspend PulseAudio while Jack is running.

Ardour recognizes the Presonus interface, I can record and when I hit the play button, the master levels are moving. I checked the audio connections settings in Ardour: the master output is connected to the two system’s playback channels. I controlled all the connections in the QjackCtl connections window - everything seems to be connected correctly, yet I can’t hear anything. The interface doesn’t seem to be receiving any signal at all. (The “USB return” button was pressed.)

I checked the playback levels of the interface with alsamixer, all 3 channels are on maximum volume.

I also tried reloading alsa - it didn’t make any difference.

I tried aplay /usr/share/sounds/alsa/Front_Center.wav - the sound came out of the internal speakers of my laptop. Maybe for some reason Ardour tries to use my internal soundcard for playback? So I tried alsa_out -d hw:2 -q 0 after starting Jack it said the device was busy, so I guess StudioLive AR16 was set correctly as output device. But I still can’t hear anything at all.

Has anybody got a clue how to fix this?

I haven’t got this mixer so I can only speculate…

  1. Make sure that channel 17/18 is unmuted and that the fader is not all the way down, but set to “U”.
  2. The mixer is said to be 18x4, but you say you can see only two system playback channels (or I got something wrong? There should be four)… anyway, in the picture of the device on site I can see another USB return button on channel 15/16 (marked 3/4 and USB icon). Try pressing that button, unmute channel 15/16 and set fader to “U”. Maybe the software mapping is set wrong and USB output returns through that channel…?
  3. You can check Input and Output devices within Qjackctl. In Qjackctl -> Setup -> Settings -> Advanced, you can select “Output device” and “Input device” separately from the dropdown menu.
  4. You may try using Alsa backend.

I hope some of this helps.

Thank you so much vasakq for your help! The StudioLive mixer is new to me so I had not realized that the playback signal comes in on channel 17/18. The fader was all the way down, that was the problem!