No playback w/ RPP255 as i/o


(Malcolm) #1

Hello everyone, I’m using v5.12.0 Intel 32-bit on a windows 8, Lenovo laptop.

I’ve been trying to connect my digitech RPP255 effect processor via usb to use as an audio interface to capture and monitor playback in Ardour.

Presently, Ardour recognizes the device just fine but I am only able to capture audio in this configuration. Playback is silent even though I can see signal bouncing on the track and master meter from the audio i just recorded on the mic. I tested to see if there was an issue with the captured audio itself by creating an new audio track and dropping a sample on there to audition. Still nothing. Then I thought it might be a port audio thing so I installed jackaudio 32bit for wndows to see if that would open up both in and out for audible playback but still no audio comes out.

I also checked a number of things on the digitech to make sure it wasn’t something silly like the usb playback volume being all the way down to zero.

Is it essential to run Jack control to get simultaneous playback and capture on the input and output? I found some good tutorials on jackaudio on windows and even after rinsing these I can’t get audio to come out the master for monitoring. I’ve tried a number of different configurations in the routing matrix on the master to see if something wasn’t wired up correctly but nothing works.

I’m not a programmer and feel I’m missing some small piece of the open source puzzle here that you smart gents can assist in.

Any help would be much appreciated.

Thanks,
Malcolm


(Chris) #2

Ardour can connect directly to audio devices with no need for jackd to run.
Can any other applications get audio out of the device?

Are you sure the mix is not set to all direct (i.e. only from the guitar pickup)? The manual has this note:
“A utility panel in the Editor/Librarian controls the direct/playback mix with any recording software
the RP255 is connected to.
Knobs 2 and 3 also control the direct/playback mix and USB record level when USB is connected
and the Pickup Row is selected.”

There was not a good enough picture that I could see in the manual, hopefully you know what is meant by knobs 2 and 3 and pickup row.


(Malcolm) #3

Thank you for your feedback. Good to know that jack audio is not essential. I did test this with a demo version of reason 9 which was able to produce playback and capture :frowning: I also did check that the levels on knobs 2 & 3 that control the usb audio were working.

One thing I didn’t add, my set up is very rudimentary at this stage and i don’t have monitors so i’m using headphones straight out the RPP255’s headphone out and not using the stereo/mono 1/4 jack outputs. I wander if that might have something to do with it. I’ll run the out put from there into my other guitar amp to test.

Thanks for your help bud. We will prevail!