No Playback - Presonus Audiobox 1818vsl

Can anybody help… I am new to Linux and am trying to configure my Presonus 1818VSL in Ardour 4.2.0 (Ubuntu Studio 14.04). All the inputs record and show level in the ardour mixer; however I cannot hear playback through interface? I can select 1818VSL from Jack, but not in Ubuntu ‘Sound’ settings; do I need a driver? The master output settings show nothing ticked; I have tried to tick masterLR to playback1/2 (and others) with no luck. I am getting frustrated, can anybody please help??..

Hi :slight_smile:

I had that happen to me. The outputs are muted. Read more here:

You don’t need any drivers for the VSL1818, its a USB Class Compliant audio device so it works with generic USB drivers that come with Linux. The DSP controlled things inside the device won’t work, but basic recording and playback with all the inputs and outputs works in Linux.

Thanks mhartzel, I tried the above. I was only able to see channels ‘midi out,0 & midi out,1’. All were unmuted. Should I have a main out to unmute?

Hi :slight_smile:

Keep 1818VLS powered off while the computer starts. Log in and then power on Presonus.

My distro is UbuntuStudio 14.04, I haven’t used the device with any newer or older distro.

In QjackCTL click “Settings” and then the arrow on the right side of the box named “Interface”, select Audiobox 1818VSL (hw:1)

Open alsamixer select Audiobox 1818VSL in the box named “Sound Card”, then click “Select Controls”. In the window that opens tick all rows.

Now some tabs with settings appear on the window, click on the tab named “Playback”. Make sure that all faders are fully up.

You can do the same thing with the text based alsamixer in the terminal. After alsamixer is running press F6 and select Audiobox 1818VSL as the sound card,

Then press F3 to select playback settings of the device. Now make sure that there are no M - letters under the faders, if there are use the arrow left and right keys to navigate on top of the fader and press m. In the picture below, there are two m’s under faders “Audiobox side” and “Audiobox”, these both will mute all output.

Now fire up Ardour and open a session with some audio in it. We will route audio to the headphone jack of the presonus, so connect also headphones to it. On Ardours main window click on: Window / Audio Connections.

There are several tabs on the window that opens now. On the left side click on tab named “Ardour busses” and on the bottom of the window click on tab called “Hardware”. Now click on the matrix so that you put a green dot on the row of Master Left just on top of “Playback 7” on the bottom of the window. This connects Ardour Left output to the left channel on the headphone jack. Now connect “Master RIght” and “Playback 8” and turn up volume on the headphones and play back the session. You should hear the playback.

If something fails, you could try to download UbuntuStudio 14.04 and boot it up from a usb stick and try the above again. You can also try a different USB cable.

Hope this helps :slight_smile:

Thanks mhartzel, I was unable to see the options in your post; so In a fit of temper I installed kxstudio. Everything worked until I rebooted! Unbelievable! I’m going to take a break from this and regroup!.. Thanks again for all your advice

You can just open another tab in your browser and copy and paste links from my post to the address field of the new tab. This will allow you to see the screenshots I took.

If everything worked correctly when running KXStudio the first time, then your hardware (computer and Presonus) are both working properly. The problem lies in software and I suspect that something keeps muteing your Presonus outputs, don’t know what though.

The Ardour forum help says the forum supports linking images to posts, but the preview function does not show them, so I don’t know if it really does. I will just add my links again here with the img - tag to see if it works. If not then just copy and paste the links to a new browser tab.

@mhartzel: links of all kinds are not made active to discourage SEO spam and make it ineffective even if posted.

Ok Paul, thanks for the info :slight_smile: The help text under the “reply” box on this forum says HTML tag < img > is allowed. Is there a way to post a reply with images emedded in it ? I guess not, if links are disabled by default.

In theory <img> should work, but apparently not. Drupal forum software sucks.

Hi mhartzel, I’m sorry I have mislead you… I was able to see your screen shots, but not options to mute/unmute channels in alsamixer (midi channels only visible). Thanks

I can not test this with my equipment since I’m just leaving for a couple of days. Going in the woods with my friend and our guitars and amplifiers. There is no-one to disturb so its going to be loud and fun :slight_smile:

Your hardware worked correctly with KXStudio when you tried it the first time, so the hardware and firmware of your presonus is ok.

Are you sure that you selected the correct sound device in the alsamixer ? There is always another sound device on your motherboard, so the mixer defaults to showing its settings. You must manually select the Presonus 1818VSL device in the mixer before you can change its settings. Does the presonus show as a device in alsamixer device selection box ?

I know there are other people on this forum that uses 1818VSL beside me, so the device works with Linux.

Can you try with another usb - cable ?

Hi Mhartzel, hope your gig in the woods was fun! I may have it sorted…I installed Ardour3 and it works! All inputs and outputs visible. I have reset a couple of times and still works. Hooray!

I hope you installed Ardour 4.4 and not Ardour 3.x

Hi Paul, it was Ardour3 that I installed. What is wrong with it? I am new to Linux and have yet to track or mix with Ardour

Ardour3 is old at this point. Ardour 4.4 was released last week. There’s not much point in us continuing to fix bugs and add features if people just continue installing old versions.

Hi Paul, I downloaded Ardour 4.2.0 two weeks ago and was not able to make it work with my Presonus 1818vsl. It was in pure frustration that I installed v3 (which works). Is there a known problem between v4.2 and Presonus 1818vsl that has now been solved with 4.4?

On GNU/Linux, Ardour does not care about the Hardware at all. Everything is provided by the Kernel/ALSA.
Ardour either uses ALSA or JACK (which also uses ALSA under the hood) to interact with the soundcard.

Ardour does also not interact with the hardware mixer (the mute issue mentioned above). If Ardour 3.X works, Ardour 4.X will also work.
How does Ardour 4.x fail for you? If you’re using JACK make sure to select “AudioSystem: JACK” in Ardour’s setup dialog.

PS. Presonus 1818VSL works just fine here with all versions of Ardour (since 2.X to latest 4.4-git) just like all other class-compliant USB devices that are supported by Linux/ALSA.

Hello all, I am having similar issues,

I open qjackctl, start the server and click connect. under the Audio tab is listed system connection under both sides readable/output and writable/input. when I expand the “system” I see capture_1, capture_2 and playback_1 , playback_2 respectively.

I open an Ardour session and a new “connection” appears on both sides. when expanded i can see busses, tracks etc. (on both sides)

When I play a session, everything works fine.

Problem is, my presonus 1818VSL is connected. In qjackctl, I selected the Presonus unit as the Interface from the list of available options, Jack evidently “sees” the device since I can select it from a list (it disappears when it’s not plugged in)

In the Ardour audio connections manager my only connection options are system options for both playback and capture.

The only evidence of the presonus unit being “seen” is in qjackctl: connect: ALSA tab, then my only two options are 0:midi through port 0 and 0:AudioBox 1818 VSL MIDI1 on both the readable and writable side.

Just a thought: are you sure you have started Ardour using Jack and not Alsa ? Start Ardour with the Jack engine.