No patch bank available

I use ardour since a few weeks. And already made a few songs. Since one day out of nothing without change anything I can´t choose new midi instruments.
There was this „general midi synth“ that once appeared automatically when I set a new track. But it´s gone and I cant find it anymore. It is not available. Instead when I now open a new track there is automatically „ace reasonable synth“ which has no patch banks available.

If I choose another available synth such as „ace fluid synth“ then I cant choose patch bank too and can´t hear anything although – based on the volume control - I can see that there should be a sound.

I don´t know what to do anymore. Please can someone help me!?

Which version of Ardour is that (Menu > Help > About)?

Ardour 6.9.0 after bach (rev 6.9) intel 64 bit

OK. I have no immediate idea, then :frowning:
I’ve asked because current nightly builds (Ardour 7.0-pre) have an issue that could explain this.

Is “General MIDI Synth” unavailable in general? If not, perhaps only the default synth was changed in the Preferences?

I still have “general midi synth” in the projects I once created. But also if I ad a new track in this older project general midi synth is not available anymore…

But I´ll have a look at the “preferences” where can I find it?

If I can chip in, out of curiosity, I checked on my system (also 6.9.0 Fedora build) and I don’t see any “General Midi Synth” in the available instruments …

Independently from this, I also don’t see where in the Preferences one can set the default instrument to be used for new MIDI Tracks/Busses… No such thing in the “MIDI” section of the preferences nor is it in the Session properties :thinking:
Note that I personally don’t miss that preference … it’s just a click in the new Track dialog … or one can use templates.

@Gogogoing a quick remark related to using ACE Fluid Synth which you say you tried.
Fluid Synth doesn’t do any sound on its own ! it’s a plugin that let’s you use SF2 SoundFonts so you have to give the plugin a SF2 file to load and only then you’ll be able to pick an instrument/patch/bank :wink:
When you double click on the plugin:

This is also where you can then assign a default instrument to each MIDI channel

If you don’t have any SF2 to play with, here’s a soundfont of the old Roland Sound Canvas that’s GM compliant)

It is bundled with binaries from Many GNU/Linux distros do not package it.

You can get the source from GitHub - x42/gmsynth.lv2: General MIDI LV2 Synth or a binary from x42 General MIDI Synth.

1 Like

Thanks so much for the help of you two! What’s funny is that it always worked and then from one day to the next no more. . . I´ll try to fix it with your pointing out.

This is the “general midi synth” i´v been talking about. This was available from the first moment I used ardour.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.