no output sound with 2.6.24

Just tried kernel 2.6.24 with newest RT patch (rt1). Everything looks fine except for one thing : I have absolutely no sound in my analog outputs (I am using RME HDSP + Multiface II). The hdspmixer app shows normal activity everywhere except in the analog outputs (even in the jack monitoring outputs of the MultifaceII). Absolute silence.

This issue is not ardour related. At least, software-wise (Jack, Ardour, Jamin, etc), everything looks normal so far. I think there’s an issue somewhere in the alsa low level layer (maybe introduced by the RT patch ?). I will try a non RT kernel from the debian rep as a reference.

Tried debian non-rt kernel 2.6.24-1-686 : same problem. I will now compile alsa from source.

there you have it : recompiled alsa v1.0.16rc2, namely all different layers - driver, lib, plugins, tools, etc, I did not want to end up with a mix of different versions. And sound output is back :slight_smile:

I will work with kernel 2.6.24 for a while, see how it behaves … (2.6.23 was not a big success in my case).

I was using the in-kernel alsa with 2.6.23.xx-rt and discovered that when I plugged in my M-Audio Oxygen 49 KB, everything sort of exploded. snd-usb-audio is/was kind of broken… it threw a bug message and knocked out my USB entirely, so no mouse… keyboard soon followed, along with a hard reset. I tried using alsa-driver-1.0.15 outside the kernel, but it didn’t help. After playing around in XP for a week or two, I came back and found 2.6.24-rt1 waiting… outside modules don’t build now, (complain of CFLAGS) but it’s OK! I went back to in-kernel kit (which is better because it allows saa-7134-alsa alongside saa-7134-dvb for this HD tuner) and everything is cool again. No more switching off the KB to boot Gentoo.

2.6.24-rt1 looking good, so far.

Now… Am I the only one with a Delta 1010LT who doesn’t get the level of DAC #1 (second channel of eight) restored when ‘alsactl restore’ runs at boot? It still stays muted until I touch the slider in envy24ctl or alsamixer… didn’t change across the upgrade, so it’s probably the way I have it set up.

I have exactly the same issue with a Multiface II and on my Gentoo amd64 system:
Kernel 2.6.24-gentoo-r3 causes absolute silence but no error messages. Using Kernel 2.6.22 has no issues. What i changes during the upgrade from 2.6.22 to 2.6.24 is I switched form realtime-lsm to PAM rlimits. I will not try to use PAM on the old Kernel to make sure that this does not causes the problem.

the same problem here with on multiface. works good though. alsa is selfcompiled, v1.0.14.


hi guys,

As i mentioned earlier, it seems related to the version of the alsa driver or lib. If you switch to Alsa v1.0.16, everything should be fine (for Debian users, it’s been in the unstable repos for a while).

I’m using the vanilla (with rt3) and it works fine, though I’m getting a really weird system lockup problem, which I thought was related to going with a realtime kernel. I’m using an RME Hammerfall 9632, I had to manually set the volume on AN1+2 so I could hear the output.

I had the same problem with the hdsp card with a MultiFace II interface. The problem is that the way the matrix mixer is addressed within the kernel driver has been changed and they got it slightly wrong.

The problem appeared with the ALSA 1.0.15 which comes as part of kernel 2.6.24. It is fixed in ALSA 1.0.16 but there is also a patch for 1.0.15 here:

The issue affects a vanilla 2.6.24 kernel and has nothing to do with apply realtime patches.

I edited my hdsp.c file in the kernel 2.6.24 tree and - voila - it works. Thanks a lot.