No other audio sources work when Ardour is running

Good morning!

SHORT VERSION: 1st post, sorry if this is redundant with another thread (and yes, I did check first).

When using Ardour in Linux, Ardour itself works fine, but ALL other audio sources are muted until after I close Ardour. This is a nuisance rather than a crisis, but I figured I’d finally ask for help resolving this!

Please help! :slight_smile:

Thanks!

(I’ll reply-to-self in the comments with a more fleshed out “LONG VERSION”)

LONG VERSION: This if my first post on the Ardour forum! I wanted to apologize profusely in advance if there is already a similar thread out there on the forum. I DID search first, of course, but didn’t find anything that deals with this issue precisely. Of course, I am uniquely bad at getting along with search engines, so my finding nothing certainly doesn’t mean that it’s not there, or even that it’s not hiding in plain sight. If an admin finds a previous thread that deals with this, I am perfectly happy if they point me to it and delete this thread. :slight_smile:

I have been podcasting since early 2017 (late 2016 is when I began production), and initially, I did all my production in GarageBand on macOS. But in February of 2020, Linux became my primary daily OS (Ubuntu Studio 19.04 [now 21.04] to be precise), and by April of 2020, I’d moved production of the podcast over to Linux as well with an Ardour-heavy mix of Ardour 5 [now Ardour 6] and Audacity.

The issue I’m writing about today is one that I’ve had from day one, but has merely been a nuisance, rather than a crisis, and so I’ve never pursued it until now. Ardour itself works fine. I can import, record, play back, edit, fade, level set, export, save, and everything else I need to do to produce my video game music podcasts, and I’m more than happy with the quality of the output and reasonably happy with the ease of use. However, my problem is that no matter how I configure the “Input Channels” or “Output Channels” on the “Audio/MIDI Setup” window (default is “all available channels”), Ardour “hogs” the audio on the computer, and mutes ALL OTHER audio sources on my computer outside of Ardour.

Again, this does not rise to the level of “crisis” for me because I can still do everything I need to do INSIDE of Ardour, and as soon as I close Ardour, all other audio sources are automatically unmuted again, with no other action required on my part to make it so. However, other than this being simply annoying, it also does create a minor hurdle in production as I can’t cross reference anything outside of Ardour without either inputting it into Ardour uneccesarily, or else closing Ardour to listen to it. So, again, not a “crisis”, but the level of “nuisance” does exceed “mere triviality”.

Is there any way to configure Ardour, or maybe perhaps, Jack to not have Ardour take everything else hostage while it’s running? Please advise. Again, I can continue to operate this way if I NEED to…but if I don’t HAVE to, I’d rather not.

I appreciate the help very much, everybody! :smiley:

Cheers!

Both JACK and Ardour take full control of the audio hardware you tell them to use. This is similar to “hog” mode on macOS or Windows.

Workflows that address this:

  1. use a JACK-enabled music player to listen to other material. There are many. I personally use Clementine, but there are at least a dozen others.

  2. Configure PulseAudio to route via JACK. This is reasonably well-documented for several different Linux distributions. There’s more than one approach to this. This will allow output from browsers and other applications that have been mis-designed to only use Pulse. I have this permanently set up on my machine - Pulse is not permitted to use any output device hardware at all, and always plays via JACK. I use Skype, Firefox and Zoom without issues.

  3. In some scenarios, use two audio interfaces, with PulseAudio using one, and pro-audio/music-create/podcasting software using the other. This can work very well for some setups (e.g. both of them feed a hardware mixer), but for other people would cause pained expression.

2 Likes

Thank you, Paul!

This gives me some things to look into! I kinda wondered if it was a JACK routing issue. :slight_smile:

Do note that none of these workflows address the situation if you use Ardour with its own ALSA audio/MIDI backend. Although that’s what we recommend for most people these days, you will need to use JACK if you want to share the audio interface hardware; Ardour’s use of it is absolute and there’s no sharing.

Note that the rapidly advancing Pipewire infrastructure for Linux will make all of this much easier for Linux users in the not too distance future (you’ll basically get workflow #2 by default, with no effort on your part).

I was having the same issues.

What worked for me was installing the pavucontrol module as described in one of the methods here:

https://askubuntu.com/questions/572120/how-to-use-jack-and-pulseaudio-alsa-at-the-same-time-on-the-same-audio-device

Scroll down until you find the entry “My solution (see theory below to understand why it works/fails and debug any potential issue”

I can now run Ardour and watch a video in Firefox, etc.

1 Like