No midi sound on record or play.. SORTED (ish)

Hi All…

Nuvva nooby prob here… Have now got Ubuntu Studio running nicely on my PC, got Ardour up and running under qjackctl, midi instruments working well with my midi keyboard controller… But as soon as I press play or record, my midi disappears… Actually, I sometimes get the first note and then it disappears… No sound, and no midi input showing on the track monitor. As soon as I stop play or record, my midi comes back and can hear it fine…

Could this be a jack config thing? or a setting in Ardour…?

Update…
Problem still remains… Have chewed through lots of posts re midi, but can only find different problems to mine… Have read the manual but cant find anything related to my issue, am pretty sure it will turn out to be a simple click to switch on monitoring of some sort. Have tried switching on/off various monitoring options but to no avail… Have not messed with jack yet as it remains a somewhat confusing interface to me… Am still on the steepest bit of the learning curve methinks…

Do you have the latest drivers installed for your audio interface? It also sounds like a problem with JACK. The default Ardour settings usually work fine.

Did you try this button?
in_button

Hi Insignia, I use a Scarlett 2i4 usb and it seems to be all working fine… Fresh copy of Ubuntustudio which I have fully updated… You might be right about jack, but it would be nice to get that working so I can try syncing Hydrogen and other funky tools I have not been able to use with Ardour yet… I will try Alsa later this evening though and report back…

Hey there cooltehno… That button is for audio I believe… It is the midi I am having a prob with… I have the correct input selected on the channel, as I mentioned the midi is working perfectly (5.8ms latency) and sound banks and instruments all select and play fine… It is when I hit play or record that the midi drops out… Am pretty sure it is simply a matter of activating some sort of monitoring in Ardour, or Jack… Still head scratching on this one…

Perfect, just let me know what you find. I also use a 2i4, so.

First, apologies cooltehno, you were quite right to point to that button, it is on the midi channel although I had it selected on mine so it was not my issue, my comment was misleading and you were correct to highlight it as a possible cause of the problem…

Sorted…! Started Ardour in ALSA mode and it all worked…! So am assuming now that this was a JACK problem and that I am going to have to get my head around that a bit more… I do find it a confusing interface though, my setup of it is always based on someone elses that I pull off the net, I would not understand it well enough if I had no guidance. Is it me, or do the inputs/outputs seem to be the wrong way round on JACK…? Perhaps if I viewed my screen through a mirror while standing on my head…?

A quick update…
The problems I am having using JACK all point to my graphics card (Nvidia 1080) constantly coming up as the primary soundcard… Been seeing a lot of stuff out there on the net about this and it seems to be problem for many folk trying to use JACK…
I did read (a little while back) about ‘blacklisting’ Nvidia devices (the audio part of them) which can keep the GPU out of the audio aspect of a PC… Once I have dug it up again, and got it to work will post a link or 2 as it may help other noobs out there.
I am sure there was some rational thinking behind making the graphics cards also an audio device, but I dont get it myself, it just gets in the way. Seems many people were hoping for an Nvidia driver which allowed us to switch off the audio but it never materialized and so the blacklisting became one of the options to work around this. Will post more as I get into this a bit further…

Ok, just done my blacklisting and found the article about it here;

https://techgage.com/news/disabling_nvidias_hdmi_audio_under_linux/

The solution to that is specify which audio device you want jackd to use rather than relying on the default.
To find out which ALSA devices are available the easiest is to use aplay -l, that tells alsaplayer to list the devices found.
For example, on my system I have a bunch of devices from the AMD graphics card (HDMI audio output), and then a couple from the USB interface I want to use:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 10: HDMI 4 [HDMI 4]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Lambda [Lexicon Lambda], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

So when starting jackd I specify as the ALSA device to use -dalsa -dhw:Lambda and that makes sure the audio goes to my Lexicon interface and not to my AMD graphics card.

Hi Chris…
Apologies for late response, spent recent times re-installing stuff and have just made time to catch up…
Did the aplay -I thing and after I blacklisted my Nvidia audio (intel sound) it came up with the following;
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: USB [Scarlett 2i4 USB], device 0: USB Audio [USB Audio]
Subdevices: 0/1
Subdevice #0: subdevice #0

Cant work out where you got -dhw from… Usually start Jack with QJackCtl so I could add something to the scripting section if you point me in the right direction? Even after blacklisting, my Nvidia comes up everywhere I look as an active audio device, often as the default device… grr… Still think an option in the driver to shut off that part of the graphics card would save a lot of folk from having to endlessly reconfigure software around it…

That “-d” is the “device” argument after you have given the -dalsa argument to tell jackd to use ALSA.
If you are using qjackctl you do not have to build the command line like that, qjackctl will do it for you , you just use the pull-down box to select which interface device you want to use, or you can type in a shortcut. So if you pull-down box just has hw:0 or hw:1 you can type in hw:Scarlett and it should use your USB device. If that shortcut doesn’t work hopefully someone else can chime in, I think Scarlett should work, but if not try 2i4.

How did you blacklist your nvidia audio? I’m confused when you write both “nvidia audio” and “intel sound,” typically those would be different things, not the same thing. Did you perhaps blacklist your Intel chipset audio driver when you thought you were blacklisting your nvidia driver? That could explain why nvidia is still showing up everywhere.

Although the output of aplay that you showed does seem to indicate that your USB interface is the only active ALSA device. Could the other applications just be showing some kind of saved configuration setting, even if it doesn’t match the currently available hardware?

https://techgage.com/news/disabling_nvidias_hdmi_audio_under_linux/

This is the link from above and I use this guide to do my blacklist of my Nvidia Graphics card. The Nvidia uses the intel audio chipset and so blacklisting just the intel will allow all the graphics functions but not the audio… Least that is my understanding of it… Seems to work for me, although I am guessing that when I install the distro, various software picks up the Nvidia as a soundcard so that when I do the blacklisting, that software had already set the Nvidia as the default device. I am still pecking away at this problem although as I mentioned, a driver from Nvidia that would allow ‘switching off’ the audio seems sensible, but Nvidia dont seemed to be inclined to do so yet…

Thanks for the info regarding QjackCtl, that is pretty much what I do already (select Scarlett hw:0 from drop down list) and it does seem to work. I do still struggle with qjackctl as I tend to visulize the connections differently to jack. Too many years messing with hifi has me seeing it a particular way I guess…

You do not have to use qjackctl to make connections in jack even if you used that tool to start jackd. Any client can make connections. Have you used the audio connection editor in Ardour? It is a grid based display with outputs along one axis and inputs along the other, you just click the box where the output row intersects the input column to make the connection you want. Once you get the idea it is very quick to setup connections, I prefer it over the qjackctl editor in most cases.

Hi Chris…
So many tools available now that I have popped in the KXStudio repositories on top of my Ubuntu Studio… I hear what you are saying about trying the audio editor in Ardour but am going to persevere with QjackCtl until I can get my head around that. I keep telling myself that it cant be that difficult to understand, just got to put in the time…
At the moment, everything is working flawlessly so dont really want to change anything until I have been able to put some hours into the setup I have. In fact it is so slick and quick, with everything working well that I am just about to go through the process of creating an iso of my whole setup so I can restore to this if something goes awry in the future…
Am finally spending time making music instead of trawling through endless guides and ‘fix it’ bloggs, and boy was it worth it… Feels like xmas at the mo with all these shiny toys to play with… All those years wasted fighting with Windoze… Now I am freeeeeeeee…!