no meter signal

guys, this ardour thing is driving me insane. so i plug in my fastrack pro hardware. all of the programs can see it. i check it in audacious with an mp3 and audacious can see it and plays it back no problem.

i configure jack, jack can see it. i start jack and there are no errors.

i open ardour. i import some songs onto a stereo track and it plays back no problem through the fast track pro box.

i plug my guitar into the fastrack pro box. I can hear the guitar but there is no signal on the meters.

i press record and nothing is recorded.

what am i doing wrong?

i want to record my next album on linux but at this rate its going to take me a month of sundays to figure out how to record 1 track. please help, im ready to give up and go back to logic. Im tired of things not working.

I guess there might be a problem with the audio connection between “system capture” (see QJackCtl) and Ardour’s recording track. Unfortunately I have no experience with Fastrack Pro, but maybe it has more than just one two track stereo input?

If this is the case, it might be similar to two cards I have worked with (RME Hammerfall 9632 and Terratec DMX6fire 24/96): though Ardour connects its recording tracks automatically to some (!) outputs of a card’s input section this is a connection just to “some” of them ;-). For example to a digital coaxial input. But the card has maybe five other inputs (Phono, analogue balanced and unbalanced, Microphone etc.), and mostly I use to work with the analogue balanced XLR input. So I have to make the right connections manually e.g. in QJackCtl or (more comfortably) in Patchage.

Maybe it’s a similar thing about your Fastrack Pro.

if this is the case then how do i know what jack calls these inputs? this thing is outrageously comfusing and complex. im stumped and beat. i dont know how to find those inputs, what they are called or what they should be changed to. i dont even know how to test them. fast track has 2 balanced ins, 2 unbalanced ins and a spdif input. if it autos to the rca unbalanced outs why would nt it default to the unbalnced ins. does anyone out there know what the ardour inputs defaults to?

i have a new name for ardour… harder

Have you tried routing inputs with the built in patchbay?

I have an FTP and I also remember struggling getting it to work initially. As I remember, the issue I had was that not all of the multiple input and output devices shown in qjackctl’s setup screen (and also in /proc/asound/devices) seemed to work – it turned out to be a matter of trying each one until I found that one that I could actually get audio through. It sounds as though you have a working output device, so it may be just a matter of choosing the right input device. Eventually I learned to look at the lists under the [>] buttons in rather than using the drop-down lists. Mine is currently set for “hw:Pro,1”, and that was working the last time I used it.

Oh, and I’m assuming when you say you can hear your guitar, that your listening to the FTP’s local monitor. (As in, you have the “Mix” knob somewhere in the middle…?) If you think that just Ardour isn’t working, have you tried patching the FTP inputs to some other program, like say, meterbridge?


(Searching for formatting options for quotes I have surrendered ;-). So I use for quotes of Dunnery’s message.)

this thing is outrageously comfusing and complex.
Please don’t be angry - we will solve your problem :-).

fast track has 2 balanced ins, 2 unbalanced ins and a spdif input.
Ah - so I suppose we have something like six “system capture” things: three stereo inputs.

i dont know how to find those inputs, what they are called or what they should be changed to.
I tried to find illustrating pictures on the WWW but actually it’s hard to find pictures with more than two system capture inputs ;-). So I have made some with my own system - you can find them under the following links.

Both pictures show the same situation with an audio card that uses an ICE1712 chip.

This is the connection window of QJackCtl:
This is the Patchage window:

Just choose the one which you like better :-).

As you can see on the left of the pictures, the system has twelve captures, that means six stereo captures. When I set up an Ardour project and (for example) a stereo audio track I get an automatic connection to system capture 1 and 2. Let’s say it’s the unbalanced RCA input for line level.

But (for example) I want a connection to the digital coaxial input. I have no idea to which numbers this input belongs. So I set up a connection from an external unit (a CD player or a DAT tape) to this coaxial input and make sure that JACK receives the signal.
Now I either arm Ardour’s audio track for recording and start to record or set the level meter of this track to “in” (to set the meter just to the input of the channel strip).
And now I connect one input after the other to the audio track - to check it out. One channel is enough, to get faster results (i.e. system capture 3, 5, 7, 9, 11). As soon as the level meter starts to move, I have found the right input. In this case it is No. 11. Now I disconnect the other ones and connect No. 12 for second channel.
And that’s it. :slight_smile:

if this is the case then how do i know what jack calls these inputs?
You will have to check it out on your individual system - unfortunately. But hey, I guess there are problems in pc world which are more difficult to solve, right? :wink:

The easiest thing is to connect each of your system inputs with a signal source with different signals and find out (as described above) which “system captures” belong to which signal/source/system input. With only three stereo inputs you will find out rather fast :-).

does anyone out there know what the ardour inputs defaults to?
It might depend on which audio card you use - and there are not very few of them…

Thank you guys. I have been trying to achieve input for about 2 weeks. I will check this out today. I will keep the thread going so others can learn from the experience.

So before I go do this please can you help me with one more point that will make it a lot easier. when ardour is active I cannot get access to any other programs. It fills up the screen and doesn’t tab like the other programs do. This means that when I go back and forth to jack I have to quit each time. Which setting is this? It would be much more practical to have a way to interchange between programs than quit all the time.


Ardour has nothing to do with that, that would be your Window Manager, at it sounds like you may have set it to use Ardour Full Screen somehow (How to do this depends on your window manager). If you know it, what desktop environment (Gnome, KDE, e17, etc.) or what window manager are you using? If you don’t know that, what distribution of Linux are you using (Ubuntu, Fedora, etc.)


I found it. Ardour has a setting called something like ‘maximize editor window’. this was the problem. It actually is an ardour window setting not a desktop setting.

So I tried the things you guys mentioned above and I managed to get audio in. but I cannot repeat it. I quit the program to access jack to see what was happening and when I went back with the same session with the same settings it is not working. no audio in and still no audio out.

question… does the top device in jack get over ridden by the input and out put devices? because once i change the input and out put device the top device drop down greys out?

So i am trying to repeat what i did to get audio in. the problem I had was that when i did get the audio in the audio out stopped working.
Guys, with all due respect, its pretty insane this stuff. I’m a very proficient computer guy, i have twenty five years of high end digital recording. I had the first pro tools when it came out and I have always been on the cutting edge of technology since the old commadore computers.

I worked with everyone under the sun and i have recorded on every device you can imagine from an old trident board to logic x. I haven’t in my life experienced the difficulty I am having with this system. it is utterly impractical. I don’t know how the program is going to catch on with these basic flaws. I am very keen to have it work because i want to get a different sound on my new album and this is one way to do it. Im sick of logics sound. but its getting close to two weeks now since i have been trying to get the thing to work. its taken me that long to get a sound out and in of the system. what must beginners think when faced with this? there doesnt seem to be a structured reliable way to have this system operate in a professional manner. its like being back in the 80s with time code sync. Anyway, thats my rant for the day. i will try again later after I have called the samaritans.

Dunnery: if this is too complex for you then please feel free to use an operating system more suited to your needs. Thousands of people use Ardour every day and do not encounter the problems you are encountering. If you wish to carry on, I strongly suggest you join us on IRC (see the Support tab at the top of this page), where we can give you real time help and get things working.

I tried that already but I don’t know how to ask a question on the chat. Anything I type or press doesn’t work. Please tell me how to ask a question.

You showed up. You didn’t type anything. Then you vanished. You were using the freenode web interface - at the bottom of the web page there is a text entry box where you can type

so i got to meet paul and the guys on the IRC but unfortunately i could only hang for 30 minutes or so. they are very helpful so i would suggest to anyone using this service to log into the support IRC at the top of the page and start a chat. the cursor on the chat is quite hidden, its at the bottom of the page so dont try and type underneath the text at the top otherwise you will look like an asshole like I did!!!
we didnt sort it out yet. the fast track pro is very confusing when it come to jack and ardour. also, online and on you tube people are saying different things on how to set it up so its a bit unclear as of yet. BUT for the forst time in two weeks i feel like I am beginning to understand whats going on. Ill keep you all posted.

in order to get the outputs to work via jack using the fast track pro you have to have the Interface menu selected to hw:pro - fastrack pro hw:1
the outputs work consistantly in all of the media players i tried. audacious amd ardour. jacl HAS to be running otherwise the whole thing is a mess.

if you want to have input from the quarter inch guitar inputs then you have to select hw:pro,1 USB audio #1 ( hw:1,1) BUT LEAVE THE OUTPUTS THE SAME AS ABOVE otherwise it will go weird again.
THANK GOD FOR THAT! I will try the balanced inputs tomorrow.

sorry, i meant to say the input device menu should be set to hw:pro,1 USB audio #1 ( hw:1,1)

and for the latest in the fast track pro insanity… i plugged in a microphone into the same input as the guitar was in. it still shows in the meters. that means that the hw:pro,1 USB audio #1 ( hw:1,1) input is for the quarter inch jack and the mic balanced in as well.