No Gui for plugins in Ardour 5.12.0

Good evening guys!
I have Ardour 5.12.0 installed on my ubuntu studio, but I just can’t find out how the plugins Gui (original interface) can be shown. I tried to find in preferences something like “show plugins Gui instead of ardour’s”, but There’s no messege like this there (maybe because the person who posted this solution has other version of ardour). Can anyone help me please?
I’d thank you a lot, and thanks for your time and attention!

It would help if you can say which plugins don’t show their gui.

No plugins show their GUI. Guitarix, landspa, LV2, Lua…They all appear as a grey screen with basic parameters, but no analysis is shown, what is a big problem for me in spectral analysers, and bothers in situations as compressors and EQ.

LADSPA, LV2 and Lua are not plugins. They are plugin APIs and a programming language respectively.

This sort of problem is almost always caused by one of two things:

  • the plugin uses a GUI toolkit that is incompatible with the host (Ardour)
  • the plugin was written in C++ and was compiled with an incompatible compiler when compared with the one used to build the host (Ardour)

What I meant was that all the plugins I tested were in these languages and showed no GUI.

And it doesn’t seem to be a problem of incompatibility, because I only have plugins autamatically installed by Ubuntu Studio in my computer.

In other words:

-I installed Ubuntu Studio in my computer (and it comes with Ardour 5.12.0 as a native program, so as lots of plugins to be used by it)

-I am trying to use some of these “lots of native plugins” in recordings I make in Ardour, but none of them shows its GUI. I tryed, for example some Guitarix plugins, so as Freeverb, and none of them shows a GUI. But I tested many other plugins from other packages (all native in Ubuntu Studio) and No GUI for all.

-It makes me believe it’s some configurarion I am not understanding where, but as I read in a post in this forum, I tried to find in preferences something like “show plugins Gui instead of ardour’s”, but There’s no messege like this in my Ardour.