No Gui for plugins in Ardour 5.12.0

Good evening guys!
I have Ardour 5.12.0 installed on my ubuntu studio, but I just can’t find out how the plugins Gui (original interface) can be shown. I tried to find in preferences something like “show plugins Gui instead of ardour’s”, but There’s no messege like this there (maybe because the person who posted this solution has other version of ardour). Can anyone help me please?
I’d thank you a lot, and thanks for your time and attention!

It would help if you can say which plugins don’t show their gui.

No plugins show their GUI. Guitarix, landspa, LV2, Lua…They all appear as a grey screen with basic parameters, but no analysis is shown, what is a big problem for me in spectral analysers, and bothers in situations as compressors and EQ.

LADSPA, LV2 and Lua are not plugins. They are plugin APIs and a programming language respectively.

This sort of problem is almost always caused by one of two things:

  • the plugin uses a GUI toolkit that is incompatible with the host (Ardour)
  • the plugin was written in C++ and was compiled with an incompatible compiler when compared with the one used to build the host (Ardour)

What I meant was that all the plugins I tested were in these languages and showed no GUI.

And it doesn’t seem to be a problem of incompatibility, because I only have plugins autamatically installed by Ubuntu Studio in my computer.

In other words:

-I installed Ubuntu Studio in my computer (and it comes with Ardour 5.12.0 as a native program, so as lots of plugins to be used by it)

-I am trying to use some of these “lots of native plugins” in recordings I make in Ardour, but none of them shows its GUI. I tryed, for example some Guitarix plugins, so as Freeverb, and none of them shows a GUI. But I tested many other plugins from other packages (all native in Ubuntu Studio) and No GUI for all.

-It makes me believe it’s some configurarion I am not understanding where, but as I read in a post in this forum, I tried to find in preferences something like “show plugins Gui instead of ardour’s”, but There’s no messege like this in my Ardour.

Do these plugins work in other audio apps (hosts) though ? Can you try with Carla or Audacity or something similar and see if they work there ?

If both versions of a plugin are installed (lv2 and ladspa) this can be a problem. ladspa plugins do not have gui and not all LV2 plugins come with a gui either (none of the a-* plugins for example) Running Ubuntu Studio here and x42eq, black pearl, eq10q, Dragonfly reverb, Gxmuff, etc. All work. I don’t seem to have calf plugins at all so I can’t try those. The guitarix plugins often install with both LV2 and ladspa, make sure to use the LV2 version to get a GUI.
I guess I should also ask which version of Studio you are using. I have 18.04 here.

Works well on a recent 19.10 ubuntu studio fresh install but I had this kind of trouble at first after installing kx repos and made an update, it even broke the zasfx gui.

I wiped hdd and made a new install without lx repos, I think I got the 18.04 ones , my mistake.

Now it works nicely with the guis