No graphical interface with Ardour 5 on Debian 10

Hello everybody out there!

I am using Debian GNU/Linux 10:

$ cat /etc/debian_version

I am running the real-time kernel from standard distribution repositories:

$ uname -a
Linux petra 5.2.0-0.bpo.2-rt-amd64 #1 SMP PREEMPT RT Debian 5.2.9-2~bpo10+1 (2019-08-25) x86_64 GNU/Linux

Pam seems to be configured:

$ ulimit -l

Though there may be something wrong with files limit:

$ ulimit -n

I am using Ardour 5 from standard distribution repositories:

$ aptitude search ardour
i   ardour                                                                                            - station de travail audionumérique                                                                          
i A ardour-data                                                                                       - station de travail audionumérique − données                                                                
i   ardour-video-timeline                                                                             - station de travail audio numérique – chronologie vidéo

When I am running Ardour with Jack running (I have tried without Jack running and I obtained the same result), I obtain no graphical interface at all, meaning I cannot use Ardour. Here is the output I get on a terminal:

$ ardour5
bind txt domain [gtk2_ardour5] to /usr/share/ardour5/locale
Ardour5.12.0 (construit avec 1:5.12.0-3 et GCC version 7.3.0)
ardour: [INFO]: Votre configuration-système limite Ardour à 1048576 fichiers ouverts
ardour: [INFO]: Chargement du fichier de configuration-système /etc/ardour5/system_config
ardour: [INFO]: Chargement du fichier de configuration-utilisateur /home/yoann/.config/ardour5/config
ardour: [INFO]: CPU vendor: GenuineIntel
ardour: [INFO]: AVX-capable processor
ardour: [INFO]: CPU brand: Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz
ardour: [INFO]: Using SSE optimized routines
ardour: [INFO]: Chargement du fichier de style par défaut (/etc/ardour5/default_ui_config) pour l'interface graphique
ardour: [INFO]: Chargement du fichier utilisateur de la configuration de l'interface graphique /home/yoann/.config/ardour5/ui_config
Couleur shuttle bg introuvable
ardour: [INFO]: Chargement du fichier de couleur /usr/share/ardour5/themes/dark-ardour.colors

And nothing more: as I said before, no graphical interface. Just this output and nothing else.

The computer I am using were running Fedora at some point, maybe configuration files got messed up. Anyway, I have tried and remove ~/.config/ardour5/, but the graphical interface still did not appear.

I have found nothing about such a problem. Can anyone help me with this?

Best regards.


1 Like

Thank you @x42. I have missed this tracker issue.

It gave me a workaround. Before running ardour, I run the following:

$ export GTK2_RC_FILES=/usr/share/themes/Adwaita/gtk-2.0/gtkrc

Then Ardour run as expected.

It seems it is a bug with GTK. Well, as most developing efforts from GTK team are on GTK 3 and 4, I guess the best chance to have this solved will be to switch to GTK 3, but migrate to a new API version needs a huge amount of work.

Well, this problem is solved anyway.

Best regards.

1 Like

There are no plans for migrate Ardour to gtk3/4 since there are no benefits from doing that.
Long term plan is to move away from GTK (since Ardour doesn’t use much of it anymore). gdk dependency is likely to remain though.

I’ve been using debian for quite some time, and here ardour has never run properly from the debian repositories. Ardour 5.12 unfortunately for me in the past(and still has on Debian 10) has complained about fonts and then does not even show the startup dialog-- so that’s why I completely ditched all ardour 5.x.x and currently using 6 beta and giving bugreports where I see them – it is actually very stable and usable… (Adrian Knoth I suppose would be the one packaging things for the .debs for debian – according to the package information page, )

When I run Ardour6 beta it does not complain at all about some font issues, shows a couple of plugin overrides that I am using and is able to start successfully.

though I haven’t updated to 10.1 yet, I will do sometime later… my version here still says 10.0

The issue at hand is unrelated to libfontconfig of Ardour5.12 binaries (new debian uses a config syntax that is not understood by the official Ardour 5.12 version from This already fixed for upcoming Ardour releases).

The problem is due to gtk2 color themes which may be optionally installed on the system, see the linked bug report for details.

1 Like

iirc I’ve been to there before — this bug is really over-due and I do not know about further details about it other than the solution (according to the package maintainer) is to try ardour from the testing repo. But imho I don’t like mixing testing repos with stable so I just download the self-installing bundle from upstream— this installs to /opt/Ardour* paths so that it will not interfere with other programs…

1 Like

Hello everybody out there!

Thank you @ahms for your response.

As far as I am concern, I use Stable and Backports packages. I do not like to mix testing repositories with stable ones either. Still, I do prefer to use packages from standard repositories.

I have sent the workaround to Debian tracking system (see the bug report). I think the best would be to integrate the workaround to the package. We will see what happens.

Best regards.