No DrumGizmo sound while playing a song

If I strike the keys in Ardour’s piano roll for the track I can hear the Drum Gizmo samples and see the master meter flashing. However if I click go to start of session and hit play, my Ardour song begins to play and the Hydrogen playback is started. However I hear none of the Drum Gizmo samples even though I see a steady stream of data in the MIDI tracker and the MIDI track’s meter is jumping up and down.

In Hydrogen I have installed a user library called DG DRS V1.1 meant to be used to drive Ardour loaded with Drum Gizmo.

The manual talks about a MIDI channel selector dialog that might be interesting but I can’t seem to find it in my Ardour 5.12.0.

Can any advise? Thanks!

If I am understanding your setup correctly, you should download A6 from this website and use that. Even using the demo would tell you if it would work, but it sounds like you want to monitor the input on playback, which A5 didn’t do I don’t believe.


For some reason the MIDI input of the plugin is not connected.
There’s only a MIDI bypass (dashed line) in the pin configuration.

Can you right-click and “reset” or manually connect the red line to the input (red diamond) of the plugin instance? That should fix this.

Thanks Robin – but that did not fix. Still no sound.

I tried toggling the automatic option as well.

Any other ideas?

As far as I can tell there’s nothing I can do GUI wise with that dashed red line.

The track also shows that you’re monitoring disk (not input). So the synth will not receive live input.

as @seablade mentioned Ardour 5 can only do either/or. In your case you have to explicitly click “In” (next to the rec-arm button).

By default Ardour does this automatically when you rec-arm the track and chose to let Ardour do the monitoring. You likely have disabled “auto-input” in the past.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.