No Ardour connection with Pipewire

To try Pipewire out, I made this on Manjaro:

$ sudo pacman -Rdd pulseaudio jack2
$ sudo pacman -S pipewire pipewire-{alsa,jack,media-session,pulse}
$ yay -S pipewire-jack-dropin
$ reboot

After that, all worked incredibly well, even better than before with Pulse-Jack sinks… all except Ardour, which does not recognize output hardware[1] and thus can not play sound and Ardour is not displaying on Carla [2] neither on QJackCtl [3].
Is this expected when removing Jack, even if pipewire-jack-dropin is installed?

[1]

[2]

[3]

Have you restarted your machine since making these changes to the audio server? Are you using the AUR or the official repo version of Pipewire?

I did restart and I am using only pipewire-jack-dropin from AUR, all other packages from official repos.

I managed to make Ardour work:

  1. Unable Try connecting audio engine automatically
  2. Open Ardour and choose Jack (already running)
  3. Enable Try connecting audio engine automatically
  4. When restarting again, it should work

mmh, that may be the source of your problems. Mixing pieces of the same software suite from different repos (which may be of different versions and/or use different build options, libraries, etc) is not a good idea, usually.

Try installing everything from the same repo (either one or the other).

I use that exact setup and it’s fine. The pipewire-jack-dropin package doesn’t exist on the official repos but the actual pipewire packages are out of date on the AUR

I am not sure what the problem is but ^this is certainly not the problem. pipewire-jack-dropin just adds a ld.so.conf file pointing to pipewire libraries so that when jack is called, it is loading the correct libraries. its a sinlge file that says /usr/lib/pipewire-0.3/jack

Pipewire-jack support for ardour is still experimental. Most problems have to do with pw-jack not having freewheel ability that native jack has. This is required for jack transport among other functions.
Upstream know of this and is working on implementing freewheel. Should be implemented soon

1 Like

I see. Then of course you’re right, that’s not the problem…

Considering you are using pacman and yay instead of pamac you might have missed the Manjaro metapackage manjaro-pipewire , that installs all the required packages from Manjaro community repository
pipewire pipewire-alsa pipewire-pulse pipewire-jack sof-firmware gst-plugin-pipewire

So all that should be required to change to Pipewire on Manjaro is

pamac install manjaro-pipewire

or

sudo pacman -S manjaro-pipewire
1 Like